This seems to be a new issue with Big Sur.

I have "App Store and identified developers" enabled in Security & Privacy, but I've run into a certain app outside the App Store that seems like it doesn't fall under the category of "identified developers".

When I try to open the app, it tells me "You do not have permission to open the application". Going into Terminal, however, I can see executable permissions are enabled for the app, just like for every other app.

What can I do to be able to open the app?

  • Same problem with Oracle's SQLDeveloper for macOS.
    – JMD
    Commented Dec 17, 2020 at 18:37
  • I am having the same problem with the printer apps found in ~/Library/Printers/ which I should 100% be able to open. 1) Right-Click+Open did not fix it. 2) Removing quarantine did not fix it. 3) The file is executable. Trying to open the app terminal gave a long string of text which means nothing to me but might to someone else: pastebin.com/raw/BLf2V8ve I am running latest public Big Sur version: 11.1 (20C69)
    – TJ Luoma
    Commented Dec 18, 2020 at 10:56
  • 1
    @JMD This may find this information useful: talkapex.com/2020/11/sqldeveloper-in-macos-big-sur
    – jaume
    Commented Dec 19, 2020 at 15:11
  • You may want to share the name and version of the app, that will help find out where the problem is. I suspect the app is not a native app (native as in Objective-C/Swift app), but a Java or Electron app, or it may need to be updated for Big Sur.
    – jaume
    Commented Dec 19, 2020 at 15:13
  • @TJLuoma What permissions are shown for the app? If you go to the folder in which it resides and do „ls -l“, what does the line with the app say? I know you enabled execution via GUI, but perhaps the GUI might be misleading here.
    – Tin Man
    Commented Dec 20, 2020 at 16:11

6 Answers 6


In playing with the Triangulator app I found the following issues on Big Sur:

  1. When decompressing the .zip, the application contents didn't retain the execute bits. Add it back with sudo chmod -R 755 /path/to/app.
  2. Since the application was downloaded by a web browser (in my case) the quarantine bits are set on the decompressed files. Remove that with sudo xattr -dr com.apple.quarantine /path/to/app.

Once those issues are remediated then the application can be launched.


  • One should not need to use sudo with xattr when removing the com.apple.quarantine extended attribute from one's own account on files already owed by the user removing the extended attribute! Commented Dec 18, 2020 at 17:44
  • 2
    My app has no quarantine flag and is executable and still won't launch. It was created by the system so it's not downloaded from the Internet.
    – TJ Luoma
    Commented Dec 18, 2020 at 20:56
  • "sudo" was needed in my case as I copied the app to the Applications folder and run as a non-admin. My account doesn't have rights to make changes to Applications when the app's rights are set to be owned by admin. Commented Dec 19, 2020 at 18:42
  • @TJLuoma Where on the disk is the application for you? The error could also be erroneous due to TCC limitations. Try moving the application to a non-TCC protected folder like /Users/Shared or /Applications. Commented Dec 19, 2020 at 18:43
  • 1
    No answer worked for everyone, and this answer worked for some people. Since @EricHoltam is new to the site, I thought it appropriate to give the bounty to him. Welcome to the site, Eric, and I hope that it will be a place that you find useful to read and contribute to for many years.
    – TJ Luoma
    Commented Dec 25, 2020 at 20:30

Good News / Bad News

Good news: I figured out how to solve the problem for my apps. (Spoiler Alert: The answer for me is: “Open in Rosetta”.)

Bad news: The same solution probably won’t work for everyone, if for no other reason than I believe people are seeing this on Intel Macs.

To recap:

Here is the error message that I was getting when I tried to open either of the two apps in ~/Library/Printers/:

You do not have permission to open the application

Trying something like this:

open ~/Library/Printers/Brother\ HL-2270DW\ series.app

would lead to this error:

The application cannot be opened for an unexpected reason, 
error=Error Domain=NSOSStatusErrorDomain Code=-10826 
"kLSNoLaunchPermissionErr: User doesn't have permission to launch the app 
(managed networks)" UserInfo={_LSFunction=_LSLaunchWithRunningboard, 
_LSLine=2508, NSUnderlyingError=0x7fa98a43e450 
{Error Domain=RBSRequestErrorDomain Code=5 "Launched process exited during launch." 
UserInfo={NSLocalizedFailureReason=Launched process exited during launch.}}}

which was not at all helpful.

  1. `open -a 'Brother HL-2270DW series' did not work.

  2. Trying to remove the quarantine flag didn't work

  3. There were no files that were not executable but should have been

  4. Right Click » Open did not prompt me to open it at all.

What fixed it

Setting these apps to “Open in Rosetta” immediately solved the issue.

Get Info » Open in Rosetta

I don’t know why.

Some further thoughts on how I got into this mess…

Needed Official Drivers from Brother

When I tried to install the printer, macOS was going to install it as a generic printer. I didn't want that, so I went to the Brother website and found the official Brother Downloads page for the HL-2270DW.

Now, that page only mentions compatibility with macOS 10.15, and I'm using Big Sur, but I guessed that it would work and probably just had not been updated for Big Sur yet because some companies take forever to do that.

“Did I install this .pkg using Rosetta? Does it matter?”

I use iTerm as my default terminal app, and I have it set to always open using Rosetta, which was recommended for making brew work with Big Sur on M1 macs.

As a result, anything that I do while using iTerm is done as if this is an Intel Mac.

Here’s the weird part: Lots of times when I run into a .pkg that I need to install, I have a shell script that runs sudo /usr/sbin/installer with the proper parameters. So chances are good that I installed the Brother drivers with that script.

In iTerm.

Running in Rosetta.

Does that matter? I really have no idea. It’s entirely possible that I could have installed this with the regular Installer.app and had the same experience. But the fact that I had to manually set the printer apps to run under Rosetta makes me at least wonder if that would have been true even if the Installer app had been running as an Apple Silicon process.

Conclusion: I should probably test that. I should also probably stop using my pkg installer shell script in iTerm (I might be able to use it in Terminal.app which I left to run as an Apple Silicon process).

Pro-Tip: Get Suspicious Package and set it as the default app for all .pkg files. It’s free and it’s fantastic.

One “Trick” that I used to help solve this…

I launched the app via lldb like so:

lldb ~/Library/Printers/Brother\ HL-2270DW\ series.app/Contents/MacOS/PrinterProxy

Once it was ready, I typed run and it worked. That’s what first tipped me off that “Open Using Rosetta” might solve it, once I remembered that iTerm was running under Rosetta which means that lldb was running as an Intel process.

Have an M1 Mac? Now you have another troubleshooting step to try.

Might take a while to get this one to soak in (at least for me), but clearly “Have you tried running it under Rosetta?” is another question we should ask ourselves/others when trying to diagnose issues on M1-based Macs.

  • Thank you so much. I just installed a printer on my m1 Mac and couldn't figure out why I couldn't open its Print Queue. I would never have thought to check "Open in Rosetta". Worked great!
    – steve
    Commented Dec 26, 2020 at 3:24
  • I had the same problem, both with a printer that had been migrated from a previous machine and then also with a newly-created one. Both HP printers where the driver was installed through the Apple native discovery and installation flow.
    – Tim Dierks
    Commented Mar 11, 2021 at 22:26
  • 1
    FIXED! Thank you. Never would have guessed this on my own. Strange that it used to work and then suddenly stopped working.
    – moof2k
    Commented Apr 10, 2021 at 2:50
  • Thanks! You are the first answer that solves my problem!
    – Labo
    Commented Apr 10, 2021 at 21:07
  • I am also seeing this same error when trying to open "side-loaded" iOS apps on Big Sur 11.3 beta 8. I am not sure if this is the result of Apple intentionally disabling using side-loaded iOS apps on M1 Macs or not, but (obviously) iOS apps do not have the option of "Open in Rosetta" so this solution will not work for them, nor has anything else I've found thus far.
    – TJ Luoma
    Commented Apr 14, 2021 at 12:26

Was having this issue with Eclipse. Stumbled across the following resources which led me to the solution:

Excerpt from the latter:

Eclipse completely ignores Apple’s long-standing prohibition of self-modifying apps. I suspect that this issue has not been resolved in the intervening years, meaning that the app modifies itself and thus breaks its own code signature.

Forcing a replacement of the application's signature fixed it for me:

% codesign --force --deep --sign - /Applications/Eclipse.app

/Applications/Eclipse.app: replacing existing signature
  • 1
    Wow! This was the solution. Thanks a ton! Somehow the codesign timestamps for my app differed by 192 seconds.
    – RileyE
    Commented Oct 14, 2021 at 17:15
  • @RileyE Excellent! Glad it helped.
    – Aaron
    Commented Oct 14, 2021 at 17:34
  • this worked for me! My app was DBeaver. Somehow it also showed a difference of 192 seconds.
    – cryanbhu
    Commented Oct 18, 2021 at 9:41

This is a known, not fully resolved problem with some apps, probably older apps which haven't been updated for Big Sur.

Here are some other things you can try in addition to the answers already given.

1. Set permissions not only for the app bundle but for all files contained within (you may have done this but it's not clear from what's been said so far):

Using Terminal, enter the following, with the trailing space

sudo chmod -R 755 

and then drag the app bundle onto the Terminal window, press enter, and enter your password if asked.

2. Using Terminal, install upx with brew:

If you don't have Homebrew installed, you can first install it with

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"

Then run brew install upx

Then run this command, substituting the path of your app's executable for the part after sudo upx -d , and enter your password if asked:

sudo upx -d /Applications/my_app.app/Contents/MacOS/my_app

To open an app bundle to find the executable, right click it in the Finder and click 'Show Package Contents'.

3. Contact the app developer to ask for any support they can give, or an updated version of the app.

This may well be all you can do at this stage, except for downgrading your Mac back to Catalina.

  • 1
    Probably the best answer! sudo upx -d works well!
    – D.A.H
    Commented Jan 13, 2021 at 7:36

Remove the ‘quarantine’ attribute from the file via:

sudo xattr -d com.apple.quarantine *FILENAME*

That should fix it.


  • Unfortunately, does not work. Here is the app I'm trying to run, if you'd like to try yourself: conceptfarm.ca/our-work/#image-triangulator .
    – Tin Man
    Commented Dec 13, 2020 at 16:31

I may have a solution. Check to see if you have two (or more) Application folders. You should only have one at the top level of your disk. Click on your hard drive and your should see your main Applications Folder (as well as Library, System and Users). If you Open Users, your username and see an Applications folder there with the problematic apps, you have found your problem. Move your apps to the Main Application folder or reinstall into that folder. You may have to Boot into Restore mode, launch Terminal and run repairHomePermissions (case sensitive) to get the installs to go into the right place.

  • 1
    Having an Applications folder in your home directory is not inherently bad; it’s a common and supported configuration. Do you have a source for your information?
    – grg
    Commented Mar 22, 2021 at 7:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .