1

I've used my iMac with an external SSD as the primary, boot disk for over a year with no issue until I've updated to Big Sur. The external disk was selected as the startup disk and on startup it would automatically boot from that disk.

After the update (and even while updating) my iMac won't automatically boot even if the disk was still selected as the startup disk. It is instead stuck prompting me to look at http://support.apple.com/mac/startup with a flashing folder icon with a question mark. To manage to boot I have to shutdown it and start it while holding the Option key, then after less than a second my SSD shows up, I can select it and the boot would proceed normally.

This is not a problem I can't live with, but I would like to fix it, especially to ease the process of updating in the future.

I recall reading about forcing the boot process to wait for all disks or a specific one to mount before continuing, but I could be thinking about a Ubuntu or Linux thing. Is this the right way, how can I do it? If not, is there another solution?


Update: I wouldn't call it a solution, but I've decided to go for a clean install, formatting the SSD and reinstalling Big Sur by booting from an a USB install media created from the installer downloaded from the AppStore. While the boot problem persisted during the installation, I managed to complete it using the Option-boot trick and after that it can now boot automatically from the external SSD (manually re-selecting it as boot disk may have played a role).

1
  • I do know that there is a bug in Big Sur where sometimes non-internal boot drives. See bombich.com/kb/ccc5/macos-big-sur-known-issues for details. Perhaps this is related to that? Unfortunately, that's as much as I know or can offer as help. Hope you find an answer! – TJ Luoma Dec 11 '20 at 23:09
1

One solution that worked for my desktop iMacs is to reset the PMU, which I accomplished on the iMac by powering off, unplugging from the wall point, and holding the power button for some seconds before replugging and powering up again.

Today I came across the same situation on my MacBook Air 2015—completely ignoring the Alt key and also ignoring the Startup Disk setting—so I reset the PMU on the MacBook Air by the conventional means. That fixed the issue, the Alt key worked to display the Startup Manager. I've noticed this behaviour coincides with a change to the startup sound, which now sounds more raucous and far less sweet. I presume that some recent update has tinkered with the firmware.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .