1

I am using a MacBook Pro (Catalina, version 10.15.5). When I click on the adobe icon at the bottom of my screen, the screen switches to another screen. Likewise, when I click on the microsoft teams icon at the bottom of my screen, it switches to another screen.

I only want one screen, however. How can avoid this problem, ensuring that when I click on the microsoft teams/adobe/etcetera it opens in the same screen?

1

I assume you're using apps in fullscreen.
All fullscreen apps get their own Space. There is no way around this.

The only 'fix' is to not use fullscreen.

8
  • Maybe I am not clear in what the problem is. Usually, when I open a pdf file, it opens in the same screen. But now it is flipping to another screen. The same with Microsoft Teams: usually I click on the Microsoft Teams icon, and it opens in the same screen. – user65526 Dec 9 '20 at 10:22
  • 1
    Look at Mission Control (default key command is Ctrl/up arrow or F3) Do you see several tabs at the top called 'Desktop 1' Desktop 2' etc, or do you see application names? If you see Desktops you have multiple Spaces enabled (which must have been done manually). If you see application names you are running those apps in fullscreen. Cmd/ctrl/F will toggle fullscreen. – Tetsujin Dec 9 '20 at 10:27
  • Yes, I have "Desktop 1" and "Desktop 2". How can I unify them? – user65526 Dec 9 '20 at 10:36
  • Hold your cursor over each one you don't want & click the X – Tetsujin Dec 9 '20 at 10:38
  • Is there no way to 'transfer across' material from Desktop 2 to Desktop 1? Also, why did this happen in the first place? Did I press some button to make it happen? – user65526 Dec 9 '20 at 10:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .