2

I am at my wit’s end here.

I’m trying to install Windows on my macOS Catalina, version 10.15.7, but BootCamp keeps saying “The disk could not be partitioned” even though I have more than enough space (400GB available for it.) I tried doing something with /sbin/fsck -y but then my computer says “error: container /dev/rdisk1 is mounted with write access”. I’ve been trying for more than a week now and I still haven’t figured anything out. We even formatted our computer just to see if it could help with the process, but it was still the same as it was before it was formatted. I have already run First Aid, but I still get my problem. Time Machine is already off.

If there is anyone willing to help me or contact me to help with this problem, please let me know because I am so close to contacting Apple Support even though I don’t live in the US. I tried using my braincells to do this, that didn’t work, I tried combining my braincells with my father’s for this, still didn’t work, so I’m really looking for any possible solutions here.

Thanks so much in advance to those who can help me and make suggestions. Cheers.

1
  • 1
    Add the output fromdiskutil list to your question. Dec 8, 2020 at 11:40

1 Answer 1

1

You may have some space taken up by local Time Machine snapshots. Run tmutil listlocalsnapshots / to see if you have any, and if you do, remove them with

for d in $(tmutil listlocalsnapshotdates | grep "-"); do sudo tmutil deletelocalsnapshots $d; done.

3
  • 1
    Type it in the terminal normally.
    – twlscnds
    Dec 9, 2020 at 5:32
  • hello! i tried this out just now but it says “Snapshots for volume group containing disk / %” and nothing else.
    – Angle
    Dec 9, 2020 at 5:40
  • Try checking for unallocated free space in Disk Utility. See this page: support.apple.com/en-ae/HT209102 for more information
    – twlscnds
    Dec 9, 2020 at 5:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .