0

I have extracted hard disks from otherwise dead Mac laptops. I'm using them as external hard disks, but I cannot use all the space they contain because they have a few system folders (like /Applications or /System) which are of no use at all to me now.

It seems I cannot delete them using the terminal (even as sudo) or with Disk Utility (If I ask this app to erase the whole volume it refuses).

Did I miss something? What is the best way to do this?

1
  • I just realized that you most likely already did what I suggested in my answer, right?
    – X_841
    Dec 6, 2020 at 19:53

1 Answer 1

1

If you go into disk utility select view then show all devices. For the drive you want to erase, select the upper most text/name and then click erase. You can now chose the name, its file system (for normal use I would recommend MacOs Extended) and its scheme (you most likely want to have GUID). Unless its an SSD you can also select security options to securely erase the data.

Make sure that all files on all volumes and its partitions of that physical drive are backed up, since you will reformat and therefore erase the actual hard drive, not just a partition.


More info about the file systems: Apple support page, APFS vs MacOS Extended

2
  • Originally, I tried a variation of this, but on my second try I applied what you suggest here and it worked. Thanks Dec 7, 2020 at 14:32
  • I am glad I could help you. Sometimes you just have to try things a second or third time and then it magically works ;)
    – X_841
    Dec 7, 2020 at 16:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .