0

This has stumped me. Printing was working normally before.

I wrote a document in Pages with text, and one horizontal divider line. I printed it, and only the line printed. After that point, I could only print graphics to the printer, not text.

Printer is a Canon imageCLASS MF8080Cw over a network. Printing the same PDF document from Windows works.

I tried:

  • Print to PDF, then print PDF. Only the line printed.
  • Save to RTF and open in Textedit, then print. Line was not exported to RTF, printed a blank page. Also printed from Libre Office, blank page.
  • In Pages, changed text colour and font. No change.
  • Printed a text chat. Emojis and bubbles printed, no text.
  • Did a screen capture and printed that from preview. Image printed fine.
  • Rebooted and tried again. Removed printer from settings, re-added, and tried again. No change.
  • Printed a printer test page from the Canon print queue. Graphics part printed fine, no text.
  • Tried to print text from Keynote, no text printed.

This baffles me. It as if a bug in Pages just made fonts disappear somewhere before the document gets sent out the network. It seems like there should be some way to reset that, but I don't know enough to know where or how. Any suggestions?

1
  • I have the same difficulty with a Canon MF641cw. I would like to know if the remove-and-reinstall-driver trick worked. – George Frazier Mar 27 at 2:21
0

In the end, I uninstalled and reinstalled the printer driver software, which fixed the problem.

3
  • Did that resolve the problem? – DavidSupportsMonica Mar 27 at 14:13
  • Yes it did, but I still don't know the cause. – John Bayko Mar 27 at 22:34
  • The fact that the problem was resolved - even if the cause remains unknown - should be included in your answer. You can use the edit button to add this info. – DavidSupportsMonica Mar 27 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .