17

Update 9-Jul-2021: This issue appears to have been resolved with macOS version 11.4. I am no longer experiencing the problem after this update.

Problem Description

Since upgrading to Big Sur I have been experiencing, sometimes multiple times per day, an issue where after waking the machine from sleep:

  1. I am unable to enter text input with the keyboard. Typing into text inputs produces the system alert sound, as if typing is not allowed. Some shortcut combinations like Cmd+Tab still work. Using the on-screen keyboard produces the same results, so it appears not to have anything to do with the keyboard hardware.

  2. I am unable to click on some kinds of UI controls with the mouse. Clicking on a window will bring it to the foreground. But links on webpages have to be double-clicked to navigate, as if the first click is ignored. Other kinds of controls such as the sidebar in Finder don't respond to clicks at all.

  3. When clicking between windows belonging to different apps, the active app in the system menubar does not update. So I may have a Finder window in the foreground, but Chrome's menu will still appear in the menubar.

  4. If I switch to a different desktop space, a different app may appear in the menubar (depending on what is open in that space) but then the menubar becomes complete unresponsive and does not respond to clicks after that.

  5. It's obvious when looking at some apps like System Preferences or Activity Monitor that even when their window has been brought to the foreground, the app isn't fully "focused", as some controls remain greyed out in the way they do when the app is in the background. (I think this gives a big clue about what's going on - is something stealing focus and won't allow any other app to be focused?).

  6. Putting the machine back to sleep does not resolve the problem, it remains in the same broken state after waking again. Using fast user switching to jump to another user profile reveals the other profile to be unaffected, but switching back to the first user returns it still in the broken state.

  7. I have tried force quitting Finder and sending kill signals to SystemUIServer and the Dock process, but this has no impact.

  8. The only solution I have found is to log out and log in again, or restart. Sometimes it is not even possible to log out, as the menubar may become unresponsive and the Cmd+Shift+Q shortcut doesn't always work, in which case a forced restart from the Login Window is required (the Login Window itself behaves normally throughout).

This issue began immediately after upgrading to Big Sur, so I think it must be a macOS bug - but as I have been unable to locate any other reports of this issue by Googling all the terms I can think of, it is conceivable that the problem results from a particular combination in my system of third-party apps or peripherals.

My machine is a MacBook Pro (16-inch, 2019) with i9 and Radeon Pro 5500M. Running Big Sur 11.0.1. I usually have a Thunderbolt 3 dock attached with external display, USB keyboard and mouse, but the problem has also occurred when roaming with nothing plugged in.

Question

Going with the focus-stealing theory, is there a way to debug this by determining which process owns the currently focused app/window in macOS? (I am able to run terminal commands by ssh'ing in from another machine when the problem occurs.)

Alternatively, is this a known issue or has anybody else experienced this? Are there other solutions or workarounds I can try to resolve the problem without logging out?

9
  • 1
    I don't have enough reputation to comment, but I have exactly the same problem. Happened immediately after upgrade from Catalina to Big Sur. I haven't found a workaround either, or any other posts that describe these symptoms. Commonalities: MacBook Pro 16 (2019) i9 Radeon 5500M, Big Sur 11.0.1. I have 2 USB3 docks, each with an HDMI external monitor and some USB input devices (mouse, joystick, pedals, IR receiver). I will try removing the USB input devices but based on your experience that is unlikely to solve the problem. Dec 5 '20 at 1:30
  • Thanks for chiming in. Good to know I'm not alone!
    – Egor
    Dec 5 '20 at 2:43
  • 2
    Also getting this issue regularly. I've tried quitting everything one by one with no luck. I'm on a MacBook Pro 16" with a USB keyboard, apple mouse and a HDMI monitor. Removing these makes no difference. In activity monitor I can see dock is using more memory, 250mb, but otherwise nothing too unusual. Also, control option and command and the space bar are functional, just all the other keys emit the noise. Only way out of it is a hard restart via the power button as the log out and log back in only works sometimes Dec 7 '20 at 8:32
  • Same problem here, it's very annoying! Dec 19 '20 at 14:05
  • I have the exact issue after upgrading to big sur. I am not usually able to resolve it without a restart even while trying the things suggested here. I am using a dock. It only happens sometimes when coming awake from sleep. I just went a month or two without it happening at all until today Jan 13 '21 at 16:49
8

This has been happening to me as well, but after reading what Juan said about Touch ID, I tried resting my finger on the Touch ID sensor and it seems to fix the focus issue. Looks like its some sort of bug where the "Use Touch ID to unlock" screen isn't showing but the desktop is being shown instead.

4
  • 1
    After I found this thread I also just tried using the touch id button again to lock and unlock my session and it resolved it. Good to know. Was maddening trying to get control back!
    – thornomad
    Dec 21 '20 at 16:02
  • This solution of fiddling with the TouchID sensor again is working for me on 11.1. It costs a few seconds delay and extra steps/hassle, but worth it to keep TouchID enabled.
    – paws
    Jan 11 '21 at 13:29
  • This solution worked for me as well (on 11.1). Hopefully it'll be fixed soon, but in the meantime it's good to know how to save myself from those maddening minutes where nothing wanted to go into focus.
    – e_known
    Jan 21 '21 at 3:06
  • 1
    I tried this, but it didn't solve it for me.
    – ldeck
    Feb 14 '21 at 7:10
7

I have not experienced this issue after disabling Touch ID unlock, by unchecking the option to Use Touch ID for: ... Unlocking your Mac in System Preferences > Touch ID.

This requires me to enter my password instead of using my fingerprint to unlock after waking from sleep. Somehow that appears to avoid this issue.

3
  • Same problem here.. I'll try this and see if it helps
    – unilynx
    Dec 10 '20 at 17:51
  • That is fantastic @egor! I’ve had to restart my computer a few times with this issue (once forcibly) as it was completely unusable. After turning off Touch ID for unlocking my Mac, so far so good. Will come back if that changes.
    – ldeck
    Jan 31 '21 at 20:38
  • 1
    I tried this @egor, but I'm still experiencing this every now and then. e.g., when a FaceTime call comes in I just experienced it today. The UI was totally unusable.
    – ldeck
    Feb 14 '21 at 7:08
2

For those of you who wish to avoid doing a hard reboot with the power button

sudo launchctl bootout gui/501

will log you out via the CLI (which might be considered preferable/more graceful way to recover). I had to do this a few times now, caveat is I already had SSH enabled and did this from a different host. (also, should mention "501" should be the desired user ID - whatever echo $UID returns).

I've run into this a few times now on my MBP16" on both 11.0.1 and 11.1, but never experienced it on Catalina. Those of you MBP16" users still on Catalina, I would suggest you stay on it until this gets sorted out.

I use an Anker USB-C hub and will have to test and see if this reoccurs without it. Didn't install any drivers for the Anker, and my Big Sur install is a clean install, not an upgrade, so all my kexts are notarized and obtained from Apple (no 3rd parties). It seems likely to me this issue is on Apple and I do hope the relevant team(s) fix soon.

If anyone knows of the appropriate Radar(s) please add a link this post.

Update: just happened again, continues to be very annoying. Used launchctl bootout to avoid the hard reboot. Will try and fiddle with TouchID next time.

Update 2: Using TouchID a subsequent time seems to be a clunky but viable workaround. TouchID once to unlock in the usual way, and again once you're in. Silly but has been working. I hope 11.2 fixes this

Update 3: I installed 11.2 recently, and have unlocked a few times. At least so far, the issue hasn't happened again. Let's hope it stays that way.

Update 4: Spoke too soon - just happened again on 11.2 :/. Seems it's not fixed unfortunately

Update 5: Just happened again on 11.2.1 :/

Update 6: Just happened again on 11.2.2, disappointing since the update description specifically called out USB-C hubs...

Update 7: +1 on 11.2.3. Anyone know the Radar #(s)?

Update 8: +1 on 11.3.0. Sigh...

0
1

Same problem for me with my MacBook Pro 13” 2020! It started happening yesterday, I think it has to be related to the 11.0.1 update because I have Big Sur installed since two weeks and I had no issue until yesterday.

In my case the only way is to shutdown MacBook from the Touch ID button and power on again. I hope Apple will launch an update soon.

1

I had exactly the same symptoms and previously added a comment. However, I then removed all 4 of my USB input devices connected via USB3 docks, and the problem has not reoccurred. The symptoms also seem to be compatible with an input device problem.

Commonalities: MacBook Pro 16 (2019) i9 Radeon 5500M, Big Sur 11.0.1.

I have 2 USB3 docks, each with an HDMI external monitor and 4 USB input devices (Logitech USB-PS/2 mouse, Microsoft Sidewinder Force Feedback 2 joystick, CH Pro Pedals USB, www.tigerfly.net Chaplet Systems IR receiver). I'm assuming one of these caused the problem and will try plugging each in in turn.

Update: unplugging USB devices made no difference. But when the problem happened, locking the computer and then unlocking with password made it functional again without a forced reboot. Agree with the proposed solution, it seems to be related to unlocking via TouchID. The same problem persists in Big Sur 11.1.

1

I've had this experience too, and my solution was to use the Touch Bar to put the laptop back to sleep, then re-awaken and unlock again. Focus came back properly the second time.

The icon to put the laptops back to sleep is a circle with a horizontal line through the lower half. If you don't have it bound, you can do so by going to System Preferences -> Keyboard -> Customise Control Strip.... and drag the icon to the Touch Bar.

4
  • I tried this without success. I think the issue occurs randomly when waking from sleep using the Touch ID sensor, so you might get lucky sometimes when re-waking, but not always.
    – Egor
    Jan 19 '21 at 18:11
  • Ah that's a shame. I have not had a chance to test out this process again, and I really don't want to disable TouchID, so I'll keep returning to this page to see if there's progress. Jan 19 '21 at 20:19
  • You can also ask Siri to put the computer to sleep if that Touch Bar item isn't in the control strip. Don't know yet if putting the computer to sleep will do the job. Will try that next time.
    – ldeck
    Feb 14 '21 at 7:20
  • Just to confirm, putting the computer to sleep and waking it back up again didn't help me.
    – ldeck
    Feb 16 '21 at 21:43
0

I've suffered with this issue for a few months now.

I've got a MacBook Pro 15" 2019.

  • 2.4 GHz 8-Core Intel Core i9
  • 32 GB 2400 MHz DDR4
  • Radeon Pro Vega 16 4 GB

I tried every suggested solution listed here.

  • TouchID enabling/disabling.
  • Putting the system to sleep and re-awakening
  • Resting my finger on the TouchID key.
  • Logging out and back in.
  • Changing the Display Scaling
  • Disconnecting/Reconnecting USB devices (like an external HD)
  • Enabling Drift Screen Saver
  • Enabling/Disabling Screen Mirroring (Airplay)
  • etc

None of them worked for me. The only thing to date that worked for me was a complete reboot.

Interestingly, some had suggested that they'd had issues with external monitors and that disconnecting it (and/or USB devices) brought some relief. I'd ignored this question for ages because I didn't ever have an external monitor connected. My issue was with the internal graphics card (I assumed).

Just now I tried something new which worked. Connecting an external monitor via HDMI through an adaptor. Boom. Flickering gone. No reboot required.

However, it's not a complete solution. When now just testing to see what happens when I disconnect the external HDMI monitor, the internal monitor's redraws and flickering issues return. Reconnecting the HDMI monitor again returns sanity.

So the fix for now (for mobility) is still a full reboot unfortunately.

2
  • You mention "flickering" - this is not one of the symptoms of the issue in this question, so I think you may be experiencing a different problem entirely?
    – Egor
    Mar 10 '21 at 22:30
  • 1
    Thanks @Egor. That's possible. What occurs for me (when it goes insane) is that there's a complete leak of UI draws and it's completely sluggish. If I open the System Preferences, for example, I have to drag the UI a few times for it to render. Clicking elements doesn't update the visual state. It's very similar to what you described in depth. The app switcher doesn't appear until I hover with the mouse over elements of it. There's lots of pixilation.
    – ldeck
    Mar 11 '21 at 23:52
0

MacBook Pro 16" 2019, macOS Big Sur 11.2.3. The issue started immediately with Big Sur upgrade, I had to reboot several times a day before I found this thread and tried all workarounds. Connecting and disconnecting external display few times restored sanity without reboot. After connecting-disconnecting external display the issue is completely gone, MBP is going from sleep OK, Touch ID is enabled.

0

I found the culprit on my system: FortiClient VPN. What happens is that whenever I get disconnected from the VPN (for example, after closing and reopening the laptop), the keyboard stops working.

The only place where it works is the FortiClient window, and if I connect again, keyword input is restored everywhere.

It looks like I'm not the only one: https://forums.macrumors.com/threads/big-sur-2020-16-inch-macbook-pro-keyboard.2269859/ and https://forum.fortinet.com/tm.aspx?m=191558

1
  • I don't use FortiClient VPN, so that sounds like a different issue. The issue here was in macOS itself, but appears to have been resolved as of v11.4.
    – Egor
    Jul 8 '21 at 21:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .