Trying to reformat a drive that was used for an employee's Time Machine and Data storage. It is a partitioned drive. Disk Utility failed to unmount the Data partition and reported the TM partition was OK, but I can't eject either without issues:

See attached. I've tried: sudo diskutil eraseDisk JHFS+ Reformat /dev/disk2 ...which resulted in an error -69888: Couldn't unmount disk.

Also tried: sudo diskutil unmount force /dev/disk2 ...which resulted in an error that it was already unmounted or "has a partitioning scheme so use 'disk util unmountDisk' instead"

However: sudo diskutil unmountDisk /dev/disk2 ...resulted in "Unmount of disk2 failed: at least one volume could not be unmounted."

When I try to reboot, the desktop icons disappear, the reboot never finishes and I end up forcing a shutdown via the power button. I've done all of the above several times.

Any ideas for untrashing this 2TB Seagate drive? Using a MacBook Pro with High Sierra. (Drive originally formatted/used on an High Sierra Mac.) Also tried an iMac which refused to mount it. terminalerrors

  • You can force unmount of the drive by using umount -f /dev/disk2s2. – Joy Jin Dec 10 '20 at 8:20

Try going to Disk Utility then press View in the menu bar and "Show All Devices". In the side bar in Disk Utility you should now see something like "2TB Seagate Drive" or something like that. Try formatting that to format the entire drive.

You can also try following this article to format it if you have a Windows computer. It has saved my drives many times

  • Thanks, Salocor. Same result as trying to format the disk via the terminal; it can't unmount the Seagate device. "Couldn't unmount disk. Operation failed..." – Wendi Dec 1 '20 at 18:30
  • Strange... Have you tried first aid on the disk? – Salocor Dec 1 '20 at 18:48
  • Yep. It reports the Time Machine partition checks out fine. The Data partition reports "Volume could not be unmounted. Restoring the original state found as mounted. Unable to unmount volume for repair. Operation failed..." If I run First Aid on the entire drive, it appears to finish without error (Operation successful) but the Disk Utiity shows the Data partition with 19.24 GB used, and it will not Erase. Attempting to double-click on the Data volume on the desktop results in a Finder pinwheel and I end up forcing a shutdown via power button. (Relaunching Finder does not work either.) – Wendi Dec 1 '20 at 19:06
  • Wow. That is really strange. Do you have a Windows computer you could try using to format it? – Salocor Dec 1 '20 at 19:08
  • Yes, I tried plugging it into a Windows 10 laptop; it doesn't see it. I'm not a Windows person, though, so there may be a workaround that I'm not familiar with. – Wendi Dec 1 '20 at 19:12

what @salocor meant was as below:

enter image description here

  • Select "Show All Device" from the view tab
  • Select the drive that you'd like to erase
  • Select Erase - MacOS Journaled with GUID Partition
  • Try and see if it works.
  • Exactly! Thanks! – Salocor Dec 1 '20 at 18:49

If you want to preserve the volume as opposed to erase the drive, here are steps...

Had the same issue and have been fighting it for days. Drive showed in Diskutil as unmounted. I couldn't mount or eject. It kept coming back as busy. I tried the various fixes suggested to do it manually in Terminal. What finally worked was this. The reason it was busy was that fsck ran as soon as I plugged the disk in.

In terminal I ran - ps aux | grep fsck followed by sudo pkill -f fsck

That stopped the fsck that had made the disk busy.

Then in the Disk Utility I selected external disk drive and ran First Aid.

After First Aid completed, about 2 hours later I was able to Mount the disk through Disk Utility. I noticed that First Aid runs fsck but with different options than what was running automatically. It runs with a -fy -x rather than just -y.

The command First Aid ran is fsck_hfs -fy -x /dev/disk2s2

I then went to Finder and did an Eject, though I'm sure I could have done that manually.

I then unplugged the cable and plugged it back in. It now appears in finder. Yea.

  • This is the answer. Eject all drives you can and then pkill fsck That will let the erase disk command proceed without needing any other steps. No need to waste time on the first aid until after you erase things in my experience. Much faster, too. You still might identify a failed drive but this is way faster than waiting for fsck. First Aid kicks off an fsck that you just killed... – bmike Feb 27 at 18:54
  • I didn’t want to do the erase and loose the data. That is partially why I did it the way I did. – RonS Feb 28 at 20:14
  • Aahh - see I was interpreting your answer in the context of this question where the goal is to erase the drive. Perhaps make this answer on a post about rescuing a drive if that’s the end goal with your answer. It might help a lot more people that way - no need to delete this here – bmike Feb 28 at 20:20

Here's the solution I found, thanks to direction from Salocor. Basically had to use a Windows PC to erase the drive via the command prompt. Windows was able to ignore whatever messed-up Mac leftovers were on the drive. Once it was clean, I plugged it back into the Mac and was prompted to "initialize". And that was that.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .