2

For the past couple of weeks, every so often (every few days perhaps) I get this popup, from 'nowhere', ie, I don't have the App Store app open. I normally see it after I've been away for a while, or overnight it greets me as I wake the screen, so I've never seen or initiated any event myself that could cause it.
Presumably this is an auto-update of something, but it doesn't say what. It's also not a general issue, other apps seem to be auto-updating as & when they like.

enter image description here

Any suggestions as to how to track it down?

I'm signed in correctly. (Messages & Facetime are also absolutely fine.) Other apps update correctly, including one just today. If I go to the Store menu > View my account it goes straight to it, no issues, no further sign in required.
As far as I'm aware I have no apps on this Mac that were purchased by any other account.

Mojave 10.14.6 on an old Mac Pro 5,1 (last available macOS for this model without needing dosdude)

  • Does this answer your question? App Store on Mojave: "We could not complete your purchase. cancelled" – djeikyb Dec 21 '20 at 20:30
  • @djeikyb - "Does this answer your question?" It may as well do - none of those solutions worked either. – Tetsujin Dec 22 '20 at 11:30
  • hey sorry about the weirdness, I didn't leave that comment! I suggested it as a duplicate, cause I followed external links from answers here that pointed to answers there, and the questions are identical. Extremely frustrating problem.. I suffer it on both my personal and work laptop 😖 I added a possible answer, but I have pretty low confidence that it's anything besides random chance.. we'll see next time I have an app update – djeikyb Dec 22 '20 at 20:22
  • 1
    My current test method is - I've switched off auto-updates. Every time I get notification of one, I run it. If it errors I delete the app & download it afresh. Worked so far, but who knows? – Tetsujin Dec 23 '20 at 8:06
  • My latest strategy is every time I get a fail I just delete the app if I haven't used it in a while. Tidier Mac, fewer nags. Win/win ;) – Tetsujin Jan 5 at 12:27
0

This is a known issue. These steps were suggested here:

https://robservatory.com/fix-a-could-not-complete-your-purchase-app-store-error/

  1. Quit the App Store app.

  2. Switch my DNS to another provider.

  3. In Terminal, paste this command and press Return:

    open "$TMPDIR/../C/com.apple.appstore/"

  4. Confirm that the Finder opened a window to the com.apple.appstore folder, then drag everything there to the trash.

  5. Back in Terminal, paste this line and press Return:

    killall -9 appstoreagent

  6. Relaunch the App Store app.

I have had this work, and I've had this not work. I've found that logging out and logging back in to the App Store has helped, and then there are times when it hasn't.

Nothing has solved it long-term, all of these are temporary fixes so far.

It just started recently, so I assume something changed on Apple's end, but I have no idea if/when a permanent solution may be forthcoming.

If anyone has a better technique for dealing with this, I hope they will share it.

Another Non-Solution Option

If you go into the Mac App Store and check for pending updates, you will see the apps that need to be updated.

If all else fails, you can delete the app and then download the new version from the Mac App Store. That works, although it is obviously not ideal.

  • I went down my list of purchases that had a cloud icon. As I'm on an older OS this also included such as Pages, etc. Pages said, 'new version too new, do you want old version?' I said yes, & that worked fine. I eventually got to 'the Unarchiver' which gave my exact error message from above. I got the non App Store version instead & hid the Store version. I guess that wasn't the most scientific method, but I'll let you know if I see the error again. – Tetsujin Dec 1 '20 at 18:06

Not the answer you're looking for? Browse other questions tagged .