I updated my Mac from 10.12.6 "Sierra" to 10.13.6 "High Sierra".

Now every app that was installed using the App Store is not able to run anymore.

They all give me the following 2 screens: enter image description here enter image description here All apps show up like they are not installed:

enter image description here

If I install them like here (5th item in list):

enter image description here

Then it still won't work. I have signed out of the App Store completely and signed in again - that resolved nothing. If I go to another tab, or re-open the App store then it shows up again like I didn't install it.

enter image description here

If I launch the apps from a terminal then I get:

Killed: 9

Which seems to be the code for a SIGKILL


Default action: Abnormal termination of the process.

Description: Kill (cannot be caught or ignored).

I tried fixing with chmod +x for the executables, but it does not fix the problem.

At this point I don't know what to do except reinstalling my whole OS. Can someone help?

  • Have you tried signing out and then back into the App Store?
    – ErniePC12
    Commented Dec 1, 2020 at 16:34
  • @ErniePC12 yes I did
    – clankill3r
    Commented Dec 1, 2020 at 17:54

2 Answers 2


Ok, I got so sick of it that I decided to reinstall my OS. I even formatted the HD, and I did not restore from any backup. While at it, I moved to 10.14.6.

When that installation was freshly done, the first thing I did was security updates and a reboot.

After that I wen't to the App Store and tried to install the app again. The error from yesterday was gone but to my surprise I got the following error:

enter image description here

Then I followed all the steps here except the Upgrade to macOS Catalina:


  1. Check Network Connectivity
  2. Verify Apple ID in App Store & iTunes
  3. Accept iTunes New Terms & Conditions
  4. Clear App Store Cookies and Cached Files
  5. Clear App Store Temporary Files
  6. -U-p-g-r-a-d-e- -t-o- -m-a-c-O-S- -C-a-t-a-l-i-n-a-
  7. Get Support from Apple

When I was on the phone, I clicked to get the same error as in the picture to make sure I didn't confuse it with yesterday error's message. And yes I still got the error. Later in the conversation he asked me to try another app, which I had done before. But magically it worked now, and suddenly all worked.

So yeah, I recommend people to call Apple, and let them do whatever it is they are doing to fix this problem.


It looks as this is all apart of a higher issue.

App Store apps do not install properly on a fresh install of High Sierra on internal SSD or HDD]

App Store apps failing to install on High Sierra

I just happen to see the following.

From a clean reboot, run in terminal “spctl --assess -v /Applications/YourApp.app”

From a Finder window, under Applications, right-click (Ctrl-Click) on your app, and select “Signer Info”

Enjoy your app

I hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .