0

My Mac crashes somewhere between once per day and once per week, when I have too many applications open. When I start it again, then I'm unable to scroll up, on my external Logitech Mouse. Scrolling down keeps working - it's just scrolling up.

I can get it to work again, by rebooting my machine and clearing the PRAM (holding down CMD + Option + P + R upon startup). So I'm pretty certain, that it's a software-issue.
However once, I got it working by simply reboot. And another time I tried that the clearing of the PRAM didn't solve it. But then I did it again, which then solved it. Really wierd!

Here are some facts:

  • It has happened about 20+ times so far, and it's always scroll-up that won't work.
  • It's not every time it crashes, but I'd say 80% of the times. My gut feeling tells me that it has something to do with, if I have been scrolling, when it crashes.
  • I have tried several different mice-models, and this is the only model it has happened with. But I don't want to switch mouse-model, since this is the best mouse across all other areas.
  • The built-in touch mouse works as it should. It's only my external mouse (the scroll-up feature) that doesn't work.
  • I've tried reconnecting the USB-cable. And the USB-cable is connected to an adapter, and I've tried reconnecting that as well.

I'm looking for a way where I can 'clear the driver cache' for the mouse? Are there any such thing?


System specs:
Mac OS: Catalina, 10.15.6
MacBook Pro (15-inch, 2016)


Update1

I just discovered that it happens with the the Mx Anywhere 2s Logitech mouse as well.

Man, this bug is annoying!

1
  • What makes you think that something called "the driver cache" is at fault? If that is the only mouse it happens with it is more likely to be a problem (hardware) with the mouse itself. – Steve Chambers Nov 30 '20 at 22:30
0

I just got it working with the Mx Anywhere 2s mouse without rebooting (!), by first uninstalling:

  • Logitech Control Center
  • Logitech Options
  • Logitech Unifying Software

And afterwards installing only Logitech Options again. By the way, I used CleanMyMac to uninstall the application and preference panes, since Logitech drizzle them all over your Mac.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .