0

I'm stuck with an odd keyboard layout in Fusion Player v 12.0.1 on macOS 10.15.7 (Catalina) and cannot seem to find a way around it.

The keyboard physically is a bluetooth Apple keyboard UK layout with tilde/back tick between he left shift and Z keys. This is set to 'British' in the system preferences and works fine (i.e. I can type `~§± and the correct symbols show in applications.

I'm running a new VM with Debian 10 in it but cannot find a way to get these keys to map correctly despite working in copy from Mac / paste to VM fine.

Is there a solution to the crossed over keys?

1
  • Since you said latest version I’ve linked to that. Please edit this if I guessed the wrong version of latest for your macOS and if you are using fusion pro instead of fusion player.
    – bmike
    Commented Nov 30, 2020 at 11:18

1 Answer 1

3
  1. Install VM Tools from the Fusion Menu (ignore notice about using open-vm-tools)
  2. Select keyboard & mouse from the VM settings
  3. Highlight Profile - default on the list of profiles
  4. From tools (cog below list of profiles) - select duplicate and name 'Debian Profile'
  5. From tools - set profile as default
  6. Double click profile and select Keyboard and Mouse
  7. Make sure Enable Key Mappings is *checked
  8. Make sure Language Specific Key Mappings is not checked
  9. Use the '+' to add a new mapping of From: § To: `
  10. Use the '+' key to add a new mapping of From: ` To: §

e.g. for the first mapping:

enter image description here

That should then take effect once you have a session running.

On the Debian side, you may have to configure the keyboard from the command line if you have not set it up / not running multiple languages.

First check if cat /etc/default/keyboard gives you:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="apple"
XKBLAYOUT="gb"
XKBVARIANT="mac"
XKBOPTIONS="lv3:ralt_switch"

BACKSPACE="guess"

If so, ignore the rest and pat yourself on the back / get a cuppa :-)

If not install the command line configurator:

sudo apt install keyboard-configuration

Then execute it:

sudo dpkg-reconfigure keyboard-configuration

Select:

  • Keyboard Model: Apple
  • Keyboard Layout: English (UK) : English (UK, Macintosh)
  • AltGr: Right Alt (AltGr)
  • Compose Key: ???? - I do not use one - select as needed
  • Control+Alt+Backspace to terminate: ???? - your choice

Then REBOOT

The other way is to add the Keyboard Layout Handler into a panel BUT this sticks a big blob of text on your menu bar! If you are happy with this (or are switching languages) then the UK keyboard can be set as:

enter image description here

Note the checkboxes for do not reset options and keep system layouts are clear.

2
  • Superbly well done explanation of a tricky sequence of steps
    – bmike
    Commented Nov 30, 2020 at 11:35
  • Thank you kindly; I've been messing around with kinto and other solutions to get this working and finally found your writeup.
    – Setomidor
    Commented Sep 20, 2021 at 7:44

You must log in to answer this question.