After I purged Xcode 4.2 and installed Xcode 4.3 from App Store, I can not find autotools (automake/autoconf) through the command line. I've tried to run find /Applications/Xcode.app -name 'automake', but apparently they are not there..

Does anyone knows what is Apple's point to remove these essential toolsets?


They moved them in 4.3 into a separate download afaik.

Try install the command line tools via Settings -> download.

enter image description here

| improve this answer | |
  • I have Command Line Tools installed, but automake is still missing. – jichi Jul 10 '14 at 20:15

For what it is worth- (and others stumbling onto this problem like I did) in the latest XCode (4.6, 4.5 and friends) autoconf is not even available in the command line tools.

I have manually installed just autoconf and a few friends, but still have trouble with some of the automake-ish software out there.

See http://jsdelfino.blogspot.com/2012/08/autoconf-and-automake-on-mac-os-x.html for a how-to to manually install.

| improve this answer | |
  • Good call - I hadn't noticed it going missing. – bmike Feb 11 '13 at 23:16

I am running Mountain Lion and have XCode 4.5.2 installed. I have installed autoconf using MacPorts:

sudo port install autoconf

I have not tried but I am sure that sudo brew install autoconf should also work for those that prefer Homebrew.

| improve this answer | |

Are you certain your PATH hasn't been corrupted? I've got the auto-tools in /usr/bin on my machine:

> ls -lah /usr/bin/auto*
-rwxr-xr-x  1 root  wheel    13K 16 May  2011 /usr/bin/autoconf
-rwxr-xr-x  1 root  wheel   8.2K 16 May  2011 /usr/bin/autoheader
-rwxr-xr-x  1 root  wheel    30K 16 May  2011 /usr/bin/autom4te
-rwxr-xr-x  2 root  wheel   227K 16 May  2011 /usr/bin/automake
-rwxr-xr-x  2 root  wheel   227K 16 May  2011 /usr/bin/automake-1.10
-rwxr-xr-x  1 root  wheel    73K  3 Feb 21:55 /usr/bin/automator
-rwxr-xr-x  1 root  wheel    20K 16 May  2011 /usr/bin/autoreconf
-rwxr-xr-x  1 root  wheel    17K 16 May  2011 /usr/bin/autoscan
-rwxr-xr-x  1 root  wheel    33K 16 May  2011 /usr/bin/autoupdate

Edit: it appears I did still have 4.2 on my machine. So this above is probably not helpful in the least.

You could try using the autoconf package from homebrew. It does not appear to be a keg that's available by default with homebrew, but you can still get it from here by placing the following in to /usr/local/Library/Formula/autoconf.rb:

require 'formula'

class Autoconf < Formula
  url 'http://ftp.gnu.org/gnu/autoconf/autoconf-2.13.tar.gz'
  homepage 'http://www.gnu.org/software/autoconf/'
  md5 '9de56d4a161a723228220b0f425dc711'

  def install
    system "./configure", "--program-suffix=213",
    system "make install"
| improve this answer | |
  • Here is mine..I installed Xcode 4.3 and even the command line tools. $ ls -lah /usr/bin/auto* -rwxr-xr-x 1 root wheel 73K Feb 1 16:28 /usr/bin/automator – eddyxu Feb 17 '12 at 18:07
  • Have you uninstalled Xcode 4.2 entirely? – eddyxu Feb 17 '12 at 22:05
  • Good catch: no. I missed that, apologies. I appear to have 4.2 on my machine still. – Ian C. Feb 17 '12 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .