Today I moved to the latest version of Xcode (4.3). I tried to open an old project and when I try to launch the iOS simulator it returns me the following error:

Xcode cannot run using the selected device.

No provisioned iOS devices are available with a compatible iOS version. Connect an 
iOS device with a recent enough version of iOS to run your application or choose an iOS 
simulator as the destination.

I also tried to create a new project and there I am able to launch the simulator.

How can I fix this problem and run all my old projects again?



The problem is that Xcode 4.3 ignores the schema you had selected in older versions, and automatically sets it to run on device for iOS projects. Since you don't have an eligible device attached to your computer, you get this error. The fix is simple. In the toolbar, click on the menu which says iOS Device and choose one of the simulator options instead.

enter image description here


Check to make sure the SDK for the targeted iOS version in the old project is still on your machine. For example, if you built the app against 4.0 and have since removed that SDK (upgrading Xcode may have done that), I would expect Xcode to present such an message.

  • Where should I look for this settings? I check in the build settings and the voice Base SDK is latest iOs, the architecture is standard arm7 – Maverik Feb 17 '12 at 19:39
  • In Xcode, select the project file in the Navigator area on the left hand side. Then select the target in the Editor. On the Summary tab, in the iOS Application Target section there is a Deployment Target option. – tlatkovich Feb 17 '12 at 19:45
  • It is set to 5.0 as well as the new project I made. But the old one doesn't work ! – Maverik Feb 17 '12 at 20:46
  • What version of iOS did you originally build your app to run on? When you click the selected option (5.0), is the original iOS version you developed the project against listed? If not, try looking for it here: iphonesdkdev.blogspot.com/2010/04/… – tlatkovich Feb 17 '12 at 20:50
  • Ops...I don't remember the original version....but I started one month ago, so I suppose it was iOs 5... – Maverik Feb 17 '12 at 20:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .