So this is my situation: Before to have the problem my mac had 2 main partitions, on the first one there was installed osx and on the second one linux. Yesterday I did cmd+r but in the while, the charger was not attached to my mac and it died. Since that moment at startup, no filesystem exists anymore and there are some problems with partitions.

enter image description here Now, what I want to do is getting back my data from osx partition and I made some attempts till now without some success:

  1. I run cmd+r (it was restored the original recover system from internet) -> disk utility -> partitions cannot be mounted and the mac osx partition type Is marked with a strange name like FFFFFF (like shown in the picture above). From disk utility seems to be nothing to do so...
  2. ...I created a bootable USB using a Linux iso(redo Recovery) and I run it trying to recover my data with some program. First of all, I cannot mount the volume where osx is located, I tried to recover my data with Gparted but it says no filesystem has been found. I tried also testdisk, it founds a lot of partitions but till now I was not able to recover anything yet:

enter image description here

Typing P, TestDisk is not able to find data anyway (it says can't open partition file system seems to be damaged or no file found, the file system may be damaged) Note that the operating system installed was Catalina (for the osx partition) So, what can I do to recover my file from that osx partition? Thanks

EDIT: I'm trying to restore the partition as suggested here: How to fix broken GPT, GUID and unmountable, no type volumes? , but I cannot understand if there is any other partition with the type ID damaged. The partition with index 2 is the partition which I have modified from ID FFFF.. to 5374:

enter image description here enter image description here

Keep in mind that I have a Linux partition installed on the system too. Help to restore it would be appreciated.

Latest Update: I tried to change the partition type as the following:

enter image description here

Now the MBR seems to be still broken but at least I had access to my account manually pressing alt at startup and choosing Machintosh HD I can recover all my data. Since we're talking about it, as education purpose info, what should I change and how to reconfigure correctly MBR to startup Catalina?

  • Your question is quite common. For example, see here. Commented Nov 30, 2020 at 0:53
  • @DavidAnderson after following who suggest that solutions should I have my partition bootable again in your opinion? The weird fact is that I'm not able to recover any data with other programs and this is a little strange
    – Virgula
    Commented Nov 30, 2020 at 9:22
  • Well, both gparted and testdisk websites show no indication of support for APFS, which is what Catalina uses. So, I would expect the results you are getting. If you continue using these tools, then you probably will not have any data to recover. Commented Nov 30, 2020 at 9:41
  • @DavidAnderson thank you I'll try what your link suggests and I'll notice here.
    – Virgula
    Commented Nov 30, 2020 at 11:11
  • @DavidAnderson I don't undertsand what is the type number for a Catalina partition, every apple osx seems to have a different standard ID for the partitions (I modified it with the number shown here: apple.stackexchange.com/questions/221114/…). I can't understand if there are other partitions with the id damaged too, I updated the question with a screen
    – Virgula
    Commented Nov 30, 2020 at 18:07


You must log in to answer this question.

Browse other questions tagged .