2

My Chrome browser is managed by organisation. This was intentional since in my previous company we used one extension for work. Thus, this is not a malware issue.

I cannot remove this policy now. I tried with following from terminal:

defaults delete com.google.Chrome ExtensionInstallForcelist

The error I get is:

Domain (com.google.Chrome) not found.
Defaults have not been changed.

These are my Policies at the moment:

ExtensionInstallForcelist is the one I want to be removed.

I also tried the Chrome Policy remover for Mac as explained here: https://support.google.com/chrome/thread/6453928?hl=en

However this is not doing anything. I tried few times, installed even signed Apple version of this tool, restarted laptop, tried from terminal, I reseted Chrome settings after it... nothing.

Any help is appreciated!

3
  • Welcome to Ask Different. Are you saying you need help removing the MDM restrictions since you are with a new company?
    – bmike
    Commented Nov 28, 2020 at 13:47
  • I want to remove it since laptop will stay with me for personal use. Commented Nov 28, 2020 at 13:56
  • In my laptop, I believe it's installed by some adware or malware, still not working. Commented Aug 26, 2023 at 4:29

1 Answer 1

1

MDM management is tricky to remove since many times, the business will force several mechanisms to prevent easy removal.

  1. Make a full backup, seriously - Time Machine to a local disk is my recommendation in addition to however you typically back up.
  2. Look in system preferences for a Profiles pane. It will not be visible if you are not MDM managed.
  3. Contact the old business - ask them to send clear written instructions on their removal process. Get it in writing. Prepare an invoice if they say it needs time or to be sent to them (many won’t divulge how to remove which isn’t fair if they’re not paying you to undo what they did to you)
  4. Proceed and if all goes wrong, you can always erase the Mac and restore from backup.

You will need to explain in much more detail what Apple signed tool you are using, but first thing is to be sure MDM isn’t foiling your attempts to manage chrome.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .