2

After upgrading to Big Sur, my Mac started announcing the time every hour.

I didn't find a way to disable announcing the time, do I maybe have to run a Terminal command?

7

You can disable this in System Preferences -> Dock & Menu Bar -> Clock

enter image description here

The setting is stored in ~/Library/Preferences/com.apple.speech.synthesis.general.prefs.plist:

$ plutil -p com.apple.speech.synthesis.general.prefs.plist
{
  "SpokenUIUseSpeakingHotKeyFlag" => 1
  "TimeAnnouncementPrefs" => {
    "TimeAnnouncementsEnabled" => 1
    "TimeAnnouncementsIntervalIdentifier" => "EveryHourInterval"
    "TimeAnnouncementsPhraseIdentifier" => "ShortTime"
    "TimeAnnouncementsVoiceSettings" => {
      "CustomVolume" => 0.5
    }
  }
}

You can use any Plist editor (or defaults) to change the setting, it may require a restart (or killing the Dock) though to get activated.

2
  • In English version its 'Dock & Menu Bar', section 'Menu Bar Only' on left pane, 'Clock' and 'Announce the time' – Aivar Paalberg Nov 28 '20 at 10:26
  • Thanks. I switched languages for the screenshot now. – nohillside Nov 28 '20 at 10:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .