8

The best example I have of font rendering problems introduced by MacOS 11.0.1 Big Sur is with iTerm2. This screenshot shows the window as it appears on the MacBook Pro (15-inch, 2018) Built-in Retina Display 15.4-inch (2880 × 1800). This is crisp and clear. enter image description here The next screenshot shows the same window, of the same size, as it appears on an external HP 24es Display 23.5-inch (1920 × 1080). The text is blurry with inconsistent line widths. enter image description here

All applications that show high contrast, light on dark fonts, are affected, iTerm is just the most painful. This problem did not occur on macOS Catalina 10.15.7 with "Use font smoothing when available" disabled.

I gained some relief using the setting

defaults -currentHost write -g AppleFontSmoothing -int 1

enter image description here

I tried all permutations of AppleFontSmoothing 1, 2, 3, CGFontRenderingFontSmoothingDisabled, and CGFontRenderingFontSmoothingEnabled. I could not perceive a difference between AppleFontSmoothing 1, 2, or 3, only that 0 was worse.
The fonts are blurry, but brighter, gross, but better. My relevant settings are

defaults read -g CGFontRenderingFontSmoothingDisabled
defaults read -g CGFontRenderingFontSmoothingEnabled
defaults -currentHost read -g AppleFontSmoothing
    null
    null
    1

I also observed the problem on a Lenovo P24q monitor with a resolution of 2560 x 1440. enter image description here

I have not heard anything from Appple Feedback (Feedback Assistant.app) and it has been 2 weeks. What can I do to improve the readability of fonts on external monitors with Big Sur? I am looking for a setting or software that can be installed.

5
  • More than likely, you need an active HDMI Adapter. Most folks use the less expensive passive adapters and macOS kexts (drivers) tend to be much less tolerant of the idiosyncrasies (like clock sync) than Windows drivers when going from DisplayPort to HDMI. The active adapter ensures a pure HDMI signal. – Allan Nov 27 '20 at 16:33
  • 2
    I am using Thunderbolt 3 to HDMI. The signal is reaching the monitor accurately, the signal being transferred is incorrect. Note that the screenshots are captured from the OS, not photographs of a monitor. – Les Grieve Dec 7 '20 at 13:58
  • 1
    Disabling Use thin strokes for anti-aliased text has helped. – relik Mar 5 at 18:10
  • Confirming that my iTerm2 -> Preferences -> Profiles -> Text -> "Use thin strokes for anti-aliased text" is set to "Never" in above screen shots. – Les Grieve Mar 8 at 12:13
  • Found related BigSur Blurry Text on external monitor. Brief update: I began suffering symptoms similar to macular degeneration, changed AppleFontSmoothing back to 0, and symptoms went away completely within 2 days. – Les Grieve Mar 25 at 15:05

You must log in to answer this question.

Browse other questions tagged .