0

My 2014 mac book pro keeps restarting. After doing a google search I found a few solutions which didn't help. I am attaching the error report , if anyone can understand the root cause please let me know.

i tried solutions found on google like booting it in safe mode and trying to recognize the problem

Also uninstalled 3rd party apps and extra peripharels but still it keeps restarting

Also alot of people say that this could be a logic board issue but i want to try all the possible software related issues before i go for the big picture

anic(cpu 2 caller 0xffffff801fe469aa): Kernel trap at 0xffffff7fa33e1b50, type 13=general protection, registers: CR0: 0x000000008001003b, CR2: 0x000000010559e000, CR3: 0x0000000022c12000, CR4: 0x00000000001626e0 RAX: 0x0000000000000000, RBX: 0xffffff803f64ea40, RCX: 0xffffff802060e0c0, RDX: 0xffffff81fcbe6000 RSP: 0xffffff820b513e90, RBP: 0xffffff820b513ea0, RSI: 0xffffff803f64ea40, RDI: 0x00ff000000000000 R8: 0xffff9fffffffffff, R9: 0x0000600000000000, R10: 0x0000000000000000, R11: 0xffffff80207f5280 R12: 0xffffff803f64ea90, R13: 0x000002208d244125, R14: 0xffffff801fd3f920, R15: 0xffffff803f312000 RFL: 0x0000000000010086, RIP: 0xffffff7fa33e1b50, CS: 0x0000000000000008, SS: 0x0000000000000010 Fault CR2: 0x000000010559e000, Error code: 0x0000000000000000, Fault CPU: 0x2, PL: 0, VF: 0

Backtrace (CPU 2), Frame : Return Address 0xffffff801fb52220 : 0xffffff801fd1a65d 0xffffff801fb52270 : 0xffffff801fe54a75 0xffffff801fb522b0 : 0xffffff801fe465fe 0xffffff801fb52300 : 0xffffff801fcc0a40 0xffffff801fb52320 : 0xffffff801fd19d27 0xffffff801fb52420 : 0xffffff801fd1a117 0xffffff801fb52470 : 0xffffff80204c1a6c 0xffffff801fb524e0 : 0xffffff801fe469aa 0xffffff801fb52660 : 0xffffff801fe466a8 0xffffff801fb526b0 : 0xffffff801fcc0a40 0xffffff801fb526d0 : 0xffffff7fa33e1b50 0xffffff820b513ea0 : 0xffffff801fe41848 0xffffff820b513ed0 : 0xffffff801fd3c4d1 0xffffff820b513f40 : 0xffffff801fd3e115 0xffffff820b513f80 : 0xffffff801fd3f99b 0xffffff820b513fa0 : 0xffffff801fcc013e Kernel Extensions in backtrace: com.apple.driver.AppleHV(1.0)[25F55CE1-4585-36A1-9EDE-2F182F9C6A19]@0xffffff7fa33de000->0xffffff7fa33e7fff

BSD process name corresponding to current thread: kernel_task

Mac OS version: 19H2

Kernel version: Darwin Kernel Version 19.6.0: Mon Aug 31 22:12:52 PDT 2020; root:xnu-6153.141.2~1/RELEASE_X86_64 Kernel UUID: 05D51A3D-3A87-3FF0-98C3-9CF3827A3EDD Kernel slide: 0x000000001fa00000 Kernel text base: 0xffffff801fc00000 __HIB text base: 0xffffff801fb00000 System model name: MacBookPro11,1 (Mac-189A3D4F975D5FFC) System shutdown begun: NO Panic diags file available: YES (0x0)

System uptime in nanoseconds: 2338833455358 last loaded kext at 771033184537: >!AXsanScheme 3 (addr 0xffffff7fa2278000, size 32768) last unloaded kext at 1666996525105: >DiskImages.KernelBacked 493.0.0 (addr 0xffffff7fa3441000, size 73728) loaded kexts:

AudioAUUC 1.70 @fileutil 20.036.15 !AGraphicsDevicePolicy 5.2.6 @AGDCPluginDisplayMetrics 5.2.6 !AHV 1 |IOUserEthernet 1.0.1 |IO!BSerialManager 7.0.6f7 !AUpstreamUserClient 3.6.8 AGPM 111.4.4 !APlatformEnabler 2.7.0d0 X86PlatformShim 1.0.0 pmtelemetry 1 !A!IHD5000Graphics 14.0.7 @Dont_Steal_Mac_OS_X 7.0.0 !AHDA 283.15 eficheck 1 !ABacklight 180.3 !AThunderboltIP 3.1.4 !ASMCLMU 212 !ALPC 3.1 AirPort.BrcmNIC 1400.1.1 !ACameraInterface 7.6.0 !A!IFramebufferAzul 14.0.7 !A!ISlowAdaptiveClocking 4.0.0 !AMCCSControl 1.14 @filesystems.autofs 3.0 !UCardReader 489.120.1 !UTCKeyboard 255 !UTCButtons 255 !AVirtIO 1.0 @filesystems.hfs.kext 522.100.5 @!AFSCompression.!AFSCompressionTypeDataless 1.0.0d1 @BootCache 40 @!AFSCompression.!AFSCompressionTypeZlib 1.0.0 @filesystems.apfs 1412.141.1 !AAHCIPort 341.140.1 @private.KextAudit 1.0 !ASmartBatteryManager 161.0.0 !ARTC 2.0 !AACPIButtons 6.1 !AHPET 1.8 !ASMBIOS 2.1 !AACPIEC 6.1 !AAPIC 1.7 $!AImage4 1 @nke.applicationfirewall 303 $TMSafetyNet 8 @!ASystemPolicy 2.0.0 |EndpointSecurity 1 !AGraphicsControl 5.2.6 |IOAVB!F 850.1 @plugin.IOgPTPPlugin 840.3 |IOEthernetAVB!C 1.1.0 DspFuncLib 283.15 @kext.OSvKernDSPLib 529 @!AGPUWrangler 5.2.6 !ABacklightExpert 1.1.0 |IONDRVSupport 576.1 !AHDA!C 283.15 |IOHDA!F 283.15 |IO80211!F 1200.12.2b1 mDNSOffloadUserClient 1.0.1b8 corecapture 1.0.4 |IOSkywalk!F 1 @!AGraphicsDeviceControl 5.2.6 |IOAccelerator!F2 438.7.3 X86PlatformPlugin 1.0.0 IOPlatformPlugin!F 6.0.0d8 |IOSlowAdaptiveClocking!F 1.0.0 !ASMBus!C 1.0.18d1 |IOGraphics!F 576.1 @kext.triggers 1.0 |Broadcom!BHost!CUSBTransport 7.0.6f7 |IO!BHost!CUSBTransport 7.0.6f7 |IO!BHost!CTransport 7.0.6f7 |IO!B!F 7.0.6f7 |IO!BPacketLogger 7.0.6f7 usb.!UHub 1.2 !UMultitouch 264 usb.IOUSBHostHIDDevice 1.2 usb.networking 5.0.0 usb.!UHostCompositeDevice 1.2 |IOAudio!F 300.2 @vecLib.kext 1.2.0 |IOSerial!F 11 |IOSurface 269.11 @filesystems.hfs.encodings.kext 1 |IOAHCIBlock!S 316.100.5 |IOAHCI!F 290.0.1 !AThunderboltDPInAdapter 6.2.6 !AThunderboltDPAdapter!F 6.2.6 !AThunderboltPCIDownAdapter 2.5.4 !AThunderboltNHI 5.8.6 |IOThunderbolt!F 7.6.1 usb.!UXHCIPCI 1.2 usb.!UXHCI 1.2 |IOUSB!F 900.4.2 !AEFINVRAM 2.1 !AEFIRuntime 2.1 |IOSMBus!F 1.1 |IOHID!F 2.0.0 $quarantine 4 $sandbox 300.0 @kext.!AMatch 1.0.0d1 DiskImages 493.0.0 !AFDEKeyStore 28.30 !AEffaceable!S 1.0 !ASSE 1.0 !AKeyStore 2 !UTDM 489.120.1 |IOSCSIBlockCommandsDevice 422.120.3 !ACredentialManager 1.0 KernelRelayHost 1 !ASEPManager 1.0.1 IOSlaveProcessor 1 |IOTimeSync!F 840.3 |IONetworking!F 3.4 |IOUSBMass!SDriver 157.140.1 |IOSCSIArchitectureModel!F 422.120.3 |IO!S!F 2.1 |IOUSBHost!F 1.2 !UHostMergeProperties 1.2 usb.!UCommon 1.0 !ABusPower!C 1.0 |CoreAnalytics!F 1 !AMobileFileIntegrity 1.0.5 @kext.CoreTrust 1 |IOReport!F 47 !AACPIPlatform 6.1 !ASMC 3.1.9 watchdog 1 |IOPCI!F 2.9 |IOACPI!F 1.4 @kec.pthread 1 @kec.Libm 1 @kec.corecrypto 1.0

4
  • 1
    Does it panic after you do a clean reinstall or follow Apple’s guidance - support.apple.com/en-us/HT200553. For this to be open here, we would need a clearer question on what you did.
    – bmike
    Commented Nov 26, 2020 at 20:43
  • Yes i have cleaned the hard disk and installed the OS again but it was of no use
    – qutub45
    Commented Nov 26, 2020 at 20:47
  • It can be time consuming to isolate, here is my best advice if you don’t want to pay someone else to do the work or work with Apple support to narrow down / repair your gear if that’s the eventual cause.
    – bmike
    Commented Nov 26, 2020 at 20:49
  • I tried to do the advice you suggested, I am only left on trying to change or clean the RAM. If that doesn't work I will have to change the computer
    – qutub45
    Commented Nov 26, 2020 at 21:04

1 Answer 1

1

This type of kernel panic is most often caused by a defective RAM module.

The kernel panic is caused by a "general protection fault" in kernel mode. This means that the kernel (the core of the operating system) tried to access memory addresses that aren't mapped to physical RAM.

The cause of this is an invalid pointer. A pointer is basically a number stored in RAM that works as an address and "points to" a different piece of the system memory.

Invalid pointers can be caused by software bugs. However, a bug that causes a kernel panic every 2-3 minutes no matter the activity would almost certainly have been discovered by other users. Those type of software bugs that cause kernel panics are usually triggered by a specific action (such as inserting an external peripheral), and not something just happening randomly.

If you have third party kernel extensions installed - disable them to test if they have any part in the kernel panic. It is also a good idea to boot up in Recovery Mode and confirm that the kernel panics also happen here, in order to rule out third party software as a cause.

Invalid pointers can also be caused by defective RAM. This I think is the most common cause for invalid pointers happening "randomly" in kernel space with a production kernel.

There are also other, less common, causes of invalid pointers, such as for example a defective CPU, a damaged memory bus, and defective PCIe DMA units.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .