0

I have used disk Utility to delete a volume and then used command line, diskutil to remove the container using,

diskutil removeContainer

Now when i type diskutil list all i see is (free space) which i cannot use anymore. I've tried doing,

diskutil apfs resizeContainer disk0s2 0

But it says, Error: -69743: The new size must be different than the existing size

Please help me on how to use that free space, i want to extend my disk0s2 to full size, thanks in advance.

The output of diskutil list is,

/dev/disk0 (internal, physical):
#: TYPE NAME SIZE       IDENTIFIER    
0:      GUID_partition_scheme             *500.3 GB   disk0    
1:      EFI ⁨EFI⁩                            209.7 MB   disk0s1
        (free space)                       201.5 GB   -    
2:      Apple_APFS ⁨Container disk1⁩         298.6 GB  disk0s2
 
/dev/disk1 (synthesized):    
#: TYPE NAME SIZE       IDENTIFIER    
0:      APFS Container Scheme -              +298.6 GB   disk1

Physical Store disk0s2    
1:        APFS Volume ⁨Vaats - Data⁩            221.0 GB   disk1s1    
2:        APFS Volume ⁨Preboot⁩                 284.7 MB   disk1s2    
3:        APFS Volume ⁨Recovery⁩                652.6 MB   disk1s3    
4:        APFS Volume ⁨VM⁩                      1.1 MB     disk1s4    
5:        APFS Volume ⁨Vaats⁩                   14.9 GB    disk1s5    
6:        APFS Snapshot ⁨com.apple.os.update-...⁩ 14.9 GB    disk1s5s1
5
  • What if you manually specify a size instead of using 0 for grow? e.g. diskutil apfs resizeContainer disk0s2 500g – negacao Nov 26 '20 at 16:24
  • When i tried, diskutil apfs resizeContainer disk0s2 100g it gave error, Error: -69605: There is not enough free space in this APFS Container for this operation – Uday Koushik Nov 26 '20 at 17:05
  • And the command diskutil apfs resizeContainer disk0s2 500g gives error, Error: -69519: The target disk is too small for this operation, or a gap is required in your partition map which is missing or too small, which is often caused by an attempt to grow a partition beyond the beginning of another partition or beyond the end of partition map usable space – Uday Koushik Nov 26 '20 at 17:08
  • Try something like 480g. – negacao Nov 26 '20 at 17:30
  • the size 480g (+298g) is greater than my HDD capacity, so it throws the same error as in case of 500g (checked) – Uday Koushik Nov 27 '20 at 2:38
2

You can not add free space that resides above a APFS container. An alternative, outlined in this answer, will not work because the APFS container is to large to be cloned to the free space you wished to add. You would need to first reduce the size of the Vaats - Data⁩ volume before applying the answer.

You could try shrinking the current APFS container and to create a new temporary partition. Move files from the APFS volume ⁨Vaats - Data⁩ to a volume in this new temporary partition. The idea would be to reduce space occupied by data in the APFS container so the APFS container could be cloned to a new APFS container you would create in the (free space). After cloning, the original APFS container be removed and the new APFS container could be expanded to reclaim the space. Next, copy the files stored in the temporary partition to the cloned APFS volume ⁨Vaats - Data⁩. Finally, remove the temporary partition and expand the new APFS container to reclaim the space.

1
  • Tried shrinking the disk, but the shrinked volume couldn't be attached to the new disk created from diskutil addpartition disk0s1 apfs NewAPFS 0 But thanks for helping me out, in creating a new disk from that free space. I ended up reinstalling macOS in that partition, move this data over to that disk and format Vaats-Data – Uday Koushik Nov 27 '20 at 7:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .