7

Since I installed macOS Big Sur, I have run into this problem every time I open a document using Word or a worksheet using Excel or a slide show in PowerPoint:

Run-time error '53':

File not found: Library/Application Support/Adobe/MACPDFM/MacPDFM.framework/Versions/A/MacPDFM

Run-time error 53

This is very annoying, as I have to dismiss this window up to four times in a row every time I open a document on these Microsoft Office applications. I searched everywhere, including the official Microsoft website, macOS tip websites, but the information was incomplete, obsolete and did not offer a practical solution.

Does anyone know how to fix this really annoying problem?

8

After looking really hard for a solution, I finally found in a very obscure page the answer, which is quite simple and works with the latest Microsoft Word on Big Sur:

  1. Close all Office applications
  2. Go to /Users/your-user-name-here/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word
  3. Remove linkCreation.dotm
  4. Restart Word and problem solved

Unfortunately that does not solve the problem for PowerPoint or Excel because if I remove SaveAsAdobePDF.ppam inside the PowerPoint folder or the SaveAsAdobePDF.xlam inside the Excel folder will trigger another error on application launch.

To fix these errors, you need to:

  1. Remove the SaveAsAdobePDF.ppam and SaveAsAdobePDF.xlam from the PowerPoint and Excel folders next to the Word folder.
  2. Launch Excel and PowerPoint and go to the menu Tools -> Excel Add-ins... and Tools -> PowerPoint Add-ins..., respectively, and remove the Save as Adobe PDF add-in, by unckecking it and removing it with the "-" button and then click OK.
  3. Restart Excel and PowerPoint and the problem should go away. If not, try several times to remove those options from the Tools menu until the problem goes away. I had to repeat this procedure in PowerPoint until this got fixed.
1
  • This fixed for me. Remove the SaveAsAdobePDF.ppam and also goto Tools--> Add-ins to remove.
    – Nirav
    Feb 23 at 16:48
1

There's a much easier way:

  1. Open Word
  2. On the top of your Mac taskbar, click "Tools"
  3. Click on "Templates and Add-ins..." at the bottom
  4. Under Global Templates and Add-ins, selected the item "linkCreation.dotm"
  5. Clicked the little (-) button to delete the item
  6. Restarted MS Word and the problem should be resolved
1
  • The file may be locked by the OS. Try this: Open Terminal, and type in the following at the prompt: "cd /Users/your-user-name-here/Library/Group Containers/UBF8T346G9.Office/User Content/Startup/Word" followed by "ls". If you see the files "linkCreation.dotm" or variations of them, do a "rm -f linkCreation.dotm" or whatever. That'll forcibly removed those files that the Word won't allow you to. Feb 19 at 7:57
1

Thank you, terminal command line worked! In case helpful for others, the only thing different for me was that 2 of the directories were appended with ".localized".
/Users/your-user-name/Library/Group Containers/UBF8T346G9.Office/User Content.localized/Startup.localized/Word

New contributor
brendag is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .