0

I'm running Big Sur (11.0.1) on a Late 2014 Mac Mini, and the Messages app refuses to stay logged in.

I recently created a child account for my eldest. Signed into her account on Mac Mini, I have successfully signed into her account in Apple ID in System Preferences, and into iCloud too.

When I open the Messages app, it prompts for credentials. I enter her creds (that I just created), and all seems to go well. I tried sending a message to my account, which was never delivered. Then, within a matter of seconds, the app appears to either restart or decides that authentication needs to be re-performed, almost like her account is being logged out. This repeats no matter how many times I try, or whether I restart the machine.

If I log into my Mac account, open Messages and log in with my Apple ID, the same thing happens. When I just tried, it lasted seven seconds before restarting.

If I open Messages using my Apple ID on a 2018 Macbook Pro, also running Big Sur, everything is fine and I can send messages to friends with iPhones, using their phone number. Similarly if I log in as her account on my MBP, I can send messages.

If I try to send a message to my child's account using my MBP, I get "Not delivered" errors.

Any ideas?

-1

What i can recommend for you is to download “iMessage debug” Its a terminal Applcation,just unzip it and double click it to run in the terminal. You will have to goto system preferences and click on the security and privacy icon and allow it to run because it will blocked because of the “unidentified developer crap” But anyhow just run that and see if that fixes your problem. If there was a known good imessage configuration on the said Mac at one point then this app will be able to restore that configuration automatically. Your ethernet in your Hardware config will have to read as “en0” and “built in”. And your nvram must be working as well. In terminal you would type the command “sudo -s” enter your password and then “sudo nvram -p” hit enter. “sudo nvram -c” now type “sudo nvram mymac=1234” where 1234 can be whatever you want to put there and then just hit enter. Then reboot and then go back to terminal and just type “sudo nvram -p” and it should bring up some data on the screen along with whatever you named the 1234 above and that way you will know if your nvram is working. If it doesnt show the 1234 rename then its not working and that would be the problem. Anyway hope this helps

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .