18

So, few bits of context

  • I've got a MacBook 12" from 2017
  • It's connected to an external monitor via USB-C to a Satechi V2 dongle and then HDMI to the monitor

I'm experiencing a few things:

  1. Stuttering when I move windows (like dropping frames)
  2. Videos stutter when my mouse pointer is in motion
  3. WindowServer in Activity Monitor shoots through the roof of CPU usage when I move my mouse a lot
  4. The above is accompanied by the beach ball

See screenshot Activity monitor with high Window Server CPU usage

I've had a bit of a speedup by disabling "Displays have seperate spaces" in the System Preferences, but it's still happening. It's also slowing down game animations as when my mouse it moving, games won't animate.

Any thoughts?

1
  • What refresh rate and resolution is your display?
    – bmike
    Mar 21, 2021 at 21:37

4 Answers 4

11

If you're using an usb mouse, I've noticed that my gaming mouse causes the WindowServer to use a lot of CPU.

Turning transparency down in accessibility settings has helped quite a bit.

As of Dec 9th, 2020, it looks like it's still happening intermittently with one 4K display and my 2019 Macbook Pro.

2
  • 4
    After a week of troubleshooting, which included a BigSur reinstall from scratch, this advise regarding a Gaming USB mouse solved my problem. I had a Corsair M65 connected. I removed it and connected my Apple bluetooth trackpad. Voila!!! Now my WindowServer process never goes over 80% even when moving a window fast around screen ... My setup is a Macbook Retina late 2013 with two monitors connected (HDMI + Thunderbolt) with macbook in clamshell mode. Dec 21, 2020 at 15:13
  • 3
    It is funny but that's the correct answer here :) I removed my steel series mouse and everything went to normal. I don't know why this is happening and who needs to fix what but this definitely fixed the issue :D
    – thinklinux
    Feb 5, 2021 at 12:56
3

You’re using an unaccelerated virtual monitor. Because your external monitor has no GPU to accelerate its graphics, all rendering is done on the CPU for that display. You can speed it up somewhat by going to the accessibility system preferences and enabling the Reduce Transparency option. But it’s always going to be much slower than an accelerated display.

3
  • There's no opacity in Accessibility->Display. Do you mean "Reduce transparency"?
    – Barmar
    Sep 5, 2021 at 3:28
  • I think you're mistaken. All monitors are accelerated by the iGPU in OPs case, just like the internal display. You can imagine that if what you suggest would be true, that would mean any MacBook or MBP with only integrated graphics would result in a terrible experience with an external monitor which is untrue. I happen to own one.
    – ovichiro
    Nov 8, 2021 at 13:31
  • @Barmar thanks, yes. I’ve updated the answer.
    – Howlium
    Nov 8, 2021 at 14:48
2

UPDATE: My original conclusion was pure coincidence.
The cause was Night Shift. I had Night Shift scheduled for sunrise - sunset. Each day at sunset while Night Shift was transitioning, for about 20 min, WindowServer would use a lot of CPU. It's a macOS bug. I disabled the schedule and do it manually when I need to. It's all been good since then.

INITIAL answer:

In my case, macOS Mojave on a MBP 13" 2015 connected to a qHD external monitor over HDMI. Logitech G305 gaming mouse.
Sometimes the fan spins up close to 4000 RPM and stays there even if I just use Finder and WindowServer shows high usage constantly.
The fix for me: disconnected the HDMI monitor, turned off the mouse, moved the mouse USB dongle to the other side, then reconnected the monitor and turned on the mouse. All was nice and quiet then.

2

My problems were completely identical with OP's, and my logs were showing the exact same results as well.

I tried many things to work this one out from my research on the Internet, but no luck.

In my case the issue was resolved by changing the refresh rate from 75Hz to 60Hz. I don't know the reason but it is magically decreased as soon as I did that. CPU usage is better than ever, no fan noise which was the most problematic issue for me. Also, changing Displays > Color > Display Profile from PHL245E1 to SD170M-A might have helped as well, but after I changed it back to HD one, no significant CPU increase or fan noise detected. Btw, I realized that the Color profiles have HD and SD modes, and in my case PHL245E1 profile is HD one while SD170M-A is, well, obviously the SD one. If someone has a 4K monitor and having issues like this, it might be of help checking these settings as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .