0

Everytime I open a terminal, I get this error: open terminal failed: not a terminal error I tried to run ps to see what program could be the problem:

    PID TTY           TIME CMD
38282 ttys003    0:01.52 -zsh
38298 ttys003    0:00.01 -zsh
38740 ttys003    0:00.00 -zsh
38741 ttys003    0:00.00 -zsh
38743 ttys003    0:00.00 /Users/anako/.cache/gitstatus/gitstatusd-darwin-x86_64 -G v1.0.0 -s -1 -u -1 -d -1 -c -1 -m -1 -v FATAL -t 8
38746 ttys003    0:00.00 (zsh)
35876 ttys004    0:02.27 -zsh
35881 ttys004    0:00.02 -zsh
36349 ttys004    0:00.02 -zsh
36350 ttys004    0:00.01 -zsh
36352 ttys004    0:00.03 /Users/anako/.cache/gitstatus/gitstatusd-darwin-x86_64 -G v1.0.0 -s -1 -u -1 -d -1 -c -1 -m -1 -v FATAL -t 8
37800 ttys004    0:00.00 (zsh)

I have seen on other question that tmux does this error message but I don't want to launch tmux at new terminal session and don't remenber setting up tmux at all.

I'm using Iterm2 on macos catalina and it also happen on native terminal app so it's not a problem with iterm.

here is my .zshrc, my zlogin only contain aliases:

# Enable Powerlevel10k instant prompt. Should stay close to the top of ~/.zshrc.
# Initialization code that may require console input (password prompts, [y/n]
# confirmations, etc.) must go above this block; everything else may go below.
if [[ -r "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh" ]]; then
  source "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh"
fi

if [[ -f $HOME/.github_token ]]
then
  export GITHUB_TOKEN=$(cat $HOME/.github_token)
fi

if [[ -f $HOME/.gitlab_token ]]
then
  export GITLAB_API_PRIVATE_TOKEN=$(cat $HOME/.gitlab_token)
fi
export GITLAB_API_ENDPOINT="https://gitlab.com/api/v4"

# If you come from bash you might have to change your $PATH.
# export PATH=$HOME/bin:/usr/local/bin:$PATH
# Path to your oh-my-zsh installation.
export ZSH="/Users/Anako/.oh-my-zsh"
export TERM="xterm-256color"
fpath=(/usr/local/share/zsh-completions $fpath)
# Set name of the theme to load --- if set to "random", it will
# load a random theme each time oh-my-zsh is loaded, in which case,
# to know which specific one was loaded, run: echo $RANDOM_THEME
# See https://github.com/robbyrussell/oh-my-zsh/wiki/Themes

# Set list of themes to pick from when loading at random
# Setting this variable when ZSH_THEME=random will cause zsh to load
# a theme from this variable instead of looking in ~/.oh-my-zsh/themes/
# If set to an empty array, this variable will have no effect.
# ZSH_THEME_RANDOM_CANDIDATES=( "robbyrussell" "agnoster" )

# Uncomment the following line to use case-sensitive completion.
#CASE_SENSITIVE="true"

# Uncomment the following line to use hyphen-insensitive completion.
# Case-sensitive completion must be off. _ and - will be interchangeable.
# HYPHEN_INSENSITIVE="true"

# Uncomment the following line to disable bi-weekly auto-update checks.
#DISABLE_AUTO_UPDATE="true"

# Uncomment the following line to automatically update without prompting.
DISABLE_UPDATE_PROMPT="true"

# Uncomment the following line to change how often to auto-update (in days).
export UPDATE_ZSH_DAYS=1

# Uncomment the following line if pasting URLs and other text is messed up.
# DISABLE_MAGIC_FUNCTIONS=true

# Uncomment the following line to disable colors in ls.
# DISABLE_LS_COLORS="true"

# Uncomment the following line to disable auto-setting terminal title.
# DISABLE_AUTO_TITLE="true"

# Uncomment the following line to enable command auto-correction.
ENABLE_CORRECTION="true"

# Uncomment the following line to display red dots whilst waiting for completion.
 #COMPLETION_WAITING_DOTS="true"

# Uncomment the following line if you want to disable marking untracked files
# under VCS as dirty. This makes repository status check for large repositories
# much, much faster.
# DISABLE_UNTRACKED_FILES_DIRTY="true"

# Uncomment the following line if you want to change the command execution time
# stamp shown in the history command output.
# You can set one of the optional three formats:
# "mm/dd/yyyy"|"dd.mm.yyyy"|"yyyy-mm-dd"
# or set a custom format using the strftime function format specifications,
# see 'man strftime' for details.
# HIST_STAMPS="mm/dd/yyyy"

# Would you like to use another custom folder than $ZSH/custom?
# ZSH_CUSTOM=/path/to/new-custom-folder

# Which plugins would you like to load?
# Standard plugins can be found in ~/.oh-my-zsh/plugins/*
# Custom plugins may be added to ~/.oh-my-zsh/custom/plugins/
# Example format: plugins=(rails git textmate ruby lighthouse)
# Add wisely, as too many plugins slow down shell startup.
plugins=(zsh-autosuggestions zsh-completions git)
#ZSH_THEME="powerlevel9k/powerlevel9k"
source $ZSH/oh-my-zsh.sh
autoload -U compinit && compinit


# User configuration

# export MANPATH="/usr/local/[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zsh[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zshman:$MANPATH"

# You may need to manually set your language environment
# export LANG=en_US.UTF-8

# Preferred editor for local and remote sessions
# if [[ -n $SSH_CONNECTION ]]; then
#   export EDITOR='vim'
# else
#   export EDITOR='mvim'
# fi

# Compilation flags
# export ARCHFLAGS="-arch x86_64"

# Set personal aliases, overriding those provided by oh-my-zsh libs,
# plugins, and themes. Aliases can be placed here, though oh-my-zsh
# users are encouraged to define aliases within the ZSH_CUSTOM folder.
# For a full list of active aliases, run `alias`.
#
# Example aliases
# alias zshconfig="mate ~/.zshrc"
# alias ohmyzsh="mate ~/.oh-my-zsh"
export PATH="/Library/Frameworks/Python.framework/Versions/3.7/bin:/Users/Anako/.rvm/gems/ruby-2.2.1/bin:/Users/Anako/.rvm/gems/ruby-2.2.1@global/bin:/Users/Anako/.rvm/rubies/ruby-2.2.1/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/share/dotnet:/opt/X11/bin:~/.dotnet/tools:/Library/Frameworks/Mono.framework/Versions/Current/Commands:/Applications/Wireshark.app/Contents/MacOS:/Applications/Xamarin Workbooks.app/Contents/SharedSupport/path-bin:/Users/Anako/.rvm/bin:/Users/Anako/.vimpkg/bin"
export PATH="/usr/local/opt/nss/bin:$PATH"

PATH="/Users/Anako/perl5/bin${PATH:+:${PATH}}"; export PATH;
PERL5LIB="/Users/Anako/perl5/lib/perl5${PERL5LIB:+:${PERL5LIB}}"; export PERL5LIB;
PERL_LOCAL_LIB_ROOT="/Users/Anako/perl5${PERL_LOCAL_LIB_ROOT:+:${PERL_LOCAL_LIB_ROOT}}"; export PERL_LOCAL_LIB_ROOT;
PERL_MB_OPT="--install_base \"/Users/Anako/perl5\""; export PERL_MB_OPT;
PERL_MM_OPT="INSTALL_BASE=/Users/Anako/perl5"; export PERL_MM_OPT;

test -e "${HOME}/.iterm2_shell_integration.zsh" && source "${HOME}/.iterm2_shell_integration.zsh"
export PATH="/usr/local/opt/libarchive/bin:$PATH"
export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
export PATH="/usr/local/opt/sqlite/bin:$PATH"

export PATH="/usr/local/bin:$PATH"

source ~/antigen/antigen.zsh
antigen use oh-my-zsh
antigen bundle supercrabtree/k
antigen bundle sudo
antigen bundle gretzky/auto-color-ls
antigen bundle MichaelAquilina/zsh-you-should-use
antigen theme romkatv/powerlevel10k
antigen apply

source /Users/anako/.oh-my-zsh/custom/plugins/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh

[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zsh
export PATH="/usr/local/opt/openssl@1.1/bin:$PATH"
export PATH="/usr/local/opt/ruby/bin:$PATH"
export PATH="/usr/local/sbin:$PATH"
export PATH="/opt/local/bin:/opt/local/sbin:$PATH"
export PATH="/usr/local/opt/libpcap/bin:$PATH"
export PATH="/Applications/LibreOffice.app/Contents/MacOS:$PATH"

export GOROOT=/usr/local/opt/go/libexec
export PATH=$PATH:$GOPATH/bin
export PATH=$PATH:$GOROOT/bin

export GOPATH=$HOME/go
export GOBIN=$GOPATH/bin
export PATH=$PATH:$GOBIN

export PATH="$(ruby -r rubygems -e 'puts Gem.user_dir')/bin:${PATH}"

# >>> conda initialize >>>
# !! Contents within this block are managed by 'conda init' !!
__conda_setup="$('/Users/Anako/opt/miniconda3/bin/conda' 'shell.zsh' 'hook' 2> /dev/null)"
if [ $? -eq 0 ]; then
    eval "$__conda_setup"
else
    if [ -f "/Users/Anako/opt/miniconda3/etc/profile.d/conda.sh" ]; then
        . "/Users/Anako/opt/miniconda3/etc/profile.d/conda.sh"
    else
        export PATH="/Users/Anako/opt/miniconda3/bin:$PATH"
    fi
fi
unset __conda_setup
# <<< conda initialize <<<
#brew completion


if type brew &>/dev/null; then
  FPATH=$(brew --prefix)/share/zsh/site-functions:$FPATH

  autoload -Uz compinit
  compinit
fi



# heroku autocomplete setup
HEROKU_AC_ZSH_SETUP_PATH=/Users/anako/Library/Caches/heroku/autocomplete/zsh_setup && test -f $HEROKU_AC_ZSH_SETUP_PATH && source $HEROKU_AC_ZSH_SETUP_PATH;
if command -v pyenv 1>/dev/null 2>&1; then
  eval "$(pyenv init -)"
fi
  • 1
    You have a pretty customized zsh setup. Do I understand correctly that your problem is just the error message "open terminal failed," and that the terminal works normally otherwise? We would have to see your .zshrc to help figure out what is causing that message. – negacao Nov 22 at 11:57
  • yes, the terminal work pretty well – anakojm Nov 22 at 12:01
  • 2
    have you tried progressively commenting-out different parts of your zshrc? – theonlygusti Nov 22 at 12:09
  • no i'll try so you think the issue is from zshrc? – anakojm Nov 22 at 12:11
  • I read my zlogin and one of my aliases was wrong syntaxed, thx! – anakojm Nov 24 at 15:46

You must log in to answer this question.

Browse other questions tagged .