17

Starting Big Sur I have Google Chrome that returns in every possible Spotlight result.

This is very annoying because if I do a typo in Spotlight and hit enter then Google Chrome shows up.

If I recall correctly before there was an option to disable this by unchecking: System Preferences > Spotlight > Allow Spotlight Suggestions in Spotlight and Look up. The option is not present anymore on Big Sur.

The only categories I have enabled in Spotlight are Applications, Calculator and System Preferences.

How can I stop this behavior from Spotlight? Or exclude Google Chrome from it?

Spotlight Result

9
  • I wonder if you add just the Google Chrome app to the privacy list in System Preferences > Spotlight if that will work. I know it works for folders but haven't tested it on an app, which is a folder... Nov 22 '20 at 0:18
  • 2
    I also feel unhappy about the behaviour. The only thing that I can do is to select what you desire the most, then the "chrome" thing will not be the first priority on spotlight results. Nov 25 '20 at 3:59
  • 4
    I made the mistake of hitting enter on just "vs" and now it always opens in chrome. I really don't want that. I wanted to open VS Code, but no matter how many times I select VS Code. Chromes suggestion is still first. This is very annoying. I only have applications listed, but Chromes suggestions still show.
    – ggedde
    Jan 10 at 4:13
  • 2
    This is awful. It's on my list of things that feel broken in big sur.
    – Z2VvZ3Vp
    Jan 27 at 18:39
  • 2
    I just ran into this too, it looks like the issue is not Chrome - it's based on the Default Web Browser. System Preferences > General > Default web browser > (Safari) - then open Safari and try the Spotlight search again. It seems like this is new Spotlight behavior...
    – sparticvs
    Feb 8 at 0:32
5

New in Big Sur’s Spotlight are web search completion results.

This is not the Google Chrome application presenting itself, but rather web search results showing in Spotlight able to be opened with the default web browser. Since your default web browser is Chrome, the icon of Chrome shows by the results.

It’s currently not possible to remove web search results from Spotlight.

1
  • If you can't disable it, this particular feature is a spyware to allow Apple to get access to our search data. Really disappointing and another big reason to not upgrade to Big Sur.
    – sfxedit
    Aug 1 at 22:07
1

You can disable one (or more) specific applications from ever showing up in Spotlight by:

  1. Moving it (or them) into a separate folder (like /Applications/private or something in your /Users/<user> folder)

  2. Adding that folder to the exclusion list in System Preferences -> Spotlight -> Privacy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .