1

Disk Utility is not giving me consistent reporting (Mojave 10.14.6 on a Macbook Air, Early 2014).

Most of the time (9 times out of 10) disk utility states there is a problem and I need to fix it in safe mode. When I run Disk Utility in safe mode, it states all is ok.

And then, once out of safe mode and back in “ordinary" mode, it repeats there is need to fix it using disk utility in safe mode.

System information states the disk is “verified”. I have tried running the trial version of DriveDX to look at the health of the disk and it says it’s “ok”.

Does anyone have an idea what I can try to fix this before I get to the point where I try formatting the disk and restoring everything?

Many thanks.

  • 1
    Do you have only 1 drive connected to your machine? – jmh Nov 21 at 21:48
  • Yes, the SSD in the Macbook. – Colin Nov 22 at 6:23
  • Could you include a screenshot or paste with the actual problem description? – jksoegaard Nov 22 at 8:45
  • Have you tried running Disk Utility in just user mode instead of safe mode? – jmh Nov 22 at 18:47
  • Thanks for your input. jksoegaard, here is the text of the error: “First Aid found corruption that needs to be repaired. To repair the startup volume, run First Aid from Recovery. Click Done to continue.” The first time I run disk utility after a reboot, it runs with no problems ; subsequent times it gives the error above. In safe and recovery mode, it runs with no problems. @jmh, I haven’t run disk utility in single user mode yet. Are we talking about “fsck -fy” or is there another way to run disk utility? Roughly how long does it take to run on an encrypted 250GB disk? Thanks. – Colin Nov 23 at 17:37

You must log in to answer this question.

Browse other questions tagged .