2

Since upgrading to Big Sur, my VPN post script has not been firing. The VPN to which I connect does not allow split tunneling.

I have a simple script in /etc/ppp/ip-up that allows me to access things outside of the network while still accessing things in the internal network. It has been working for a while now and ever since upgrading to Big Sur, I have to run the command manually to be able to access external websites/services. It is set to be executable and everything so I don't know what the problem is, below is what that file looks like.

#!/bin/sh

/sbin/route change default 192.168.1.1

If I run the command in Terminal it works, so I'm curious if Apple broke something or changed how it works.

Did something major change with how macOS handles this file?

0
2

Same here ... it was working for a while though.

What seems to work is:

networksetup -setadditionalroutes <networkservice> [ <dest> <mask> <gateway> ]*

To find out the adapter names use:

networksetup -listallnetworkservices

Example:

networksetup -setadditionalroutes "name of your VPN" 192.168.1.0 255.255.255.0 192.168.10.254 192.168.2.0 255.255.255.0 192.168.10.254
3
  • For your case (where you're changing the default route) this may not be helpful. Also this probably only works for connections that are not managed by a third party client.
    – otto
    Jan 26 at 12:49
  • 1
    There used to be other ways to run scripts when a NIC comes up - maybe some of them still work in Big Sur. apple.stackexchange.com/questions/32354/… You would only need to ensure that it is only run if your VPN connection is up (ppp0 is up).
    – otto
    Jan 26 at 13:04
  • I only did it that way because it worked, on my windows laptop I use at work it does a route change but I couldn't figure out how to do that on Mac so I used the command above which did the trick until Big Sur broke it.
    – Eddie
    Jan 26 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .