2

What I did:

  • Created a custom non-iCloud, non-system photo library and imported my photos from an external camera.
  • All photos are referenced from external files, i.e. not embedded into the library file.
  • Each photo has valid GPS information embedded.

What works:

  • Swiping up when viewing each photo does show it on a map:

    Imgur

  • So does right-click → Get Info:

    Imgur

  • When I ++i the actual file in Finder, it shows the raw latitude and longitude:

    Imgur

What doesn't work:

  • Clicking Show Nearby Photos shows an empty map, although I know for a fact there actually are other photos that I've taken nearby:

    Imgur

    All those other nearby photos had been added to this very library, and when checked individually, they show up on the map just fine.

  • The dedicated places map shows no photos at all, including the photo we just confirmed has a known, valid and parse-able location:

    Imgur

I had an Apple support rep connected to my Mac via remote desktop trying to figure this out a few months back. After a few hours, his conclusion was that this may be a glitch specific to my machine. He suggested a full OS reinstall or trying one of my photos on someone else's Mac Photos app, which I did a few days ago. I imported a file into my friend's default iCloud library and his every other photo showed up on the Places map, except mine. The swipe up map still worked though. So I have basically reproduced pretty much the same behaviour I'm experiencing on my Macbook.

Please help me figure this out!

I'm on macOS Catalina 10.15.7, and here is the photo I have used (note how Onedrive was able to parse out the location too).

UPDATE

Thanks to the comments, I've taken a closer look at the facial recognition in this library:

  • It works, but isn't as pro-active as in the system/iCloud library. As in, it detects faces, and sometimes even links them to previously defined people, but most of the time I have to manually assign a face to a person. Could be because these photos aren't originally digital, these are film photos.

  • Here's the kicker. Once a person has a few photos linked, it does show them all on a map on that person's page, just like it should.

    Imgur

    Similarly to an individual photo, this view also has Show Nearby Photos, but when I click it, the new map that opens is once again empty.

3
  • I haven’t tested if the curation process even runs on non system libraries. How many photos are in this? I would make a library with 5 photos and let it sit in the Photos view until curation is complete with the app running (background or off screen in Mission Control virtual screen is fine. Just let the app be backgrounded and take CPU time to process the metadata)
    – bmike
    Commented Nov 18, 2020 at 17:26
  • @bmike Hi, thank you for your comment. This custom library has ~1500 photos. Sadly I can't answer regarding the curation process, but I did consciously leave the app opened many times for the facial recognition to complete, and it kinda did, judging by how it recognised a few people.
    – WhatHiFi
    Commented Nov 18, 2020 at 17:46
  • I would make a new library to be sure the function works, then repair the other one... (or let it run over a weekend)
    – bmike
    Commented Nov 18, 2020 at 17:53

1 Answer 1

0

Good news: I randomly opened this custom library for the first time in months, if not years, and it turns out everything works now.

  • The Places map now has all photos plotted
  • Facial recognition seems to be stable. I will, however, go through every photo in the library making sure if someone is there he/she is identified and linked to the People tab
  • The map on every person's page has all respective photos

Not sure what fixed it. I do remeber being on a call with Apple support back in 2020/2021, being transferred to someone from the engineering (?), and spending a good few hours looking into this. Could be that he made a bug report and it got fixed eventually.

I have an old MacBook Pro 2015 updated to the latest macOS Monterey 12.7 right before trying yesterday. The Photos version is 7.0 (460.0.120).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .