37

As of Big Sur, every time I open or unlock my Mac or walk over to it from being somewhere else I get this notification:

AirPods Nearby Notification Center Notification

AirPods
Nearby

I don't need it, dismissing it is a distraction and waiting for it to disappear is an obstruction to getting work done.

How and turn it off so I never get notifications about my Airpods?

2 Answers 2

28

Connect your AirPods to your Mac, then go to System Preferences → Bluetooth and for your AirPods choose Options and set ‘Connect to This Mac’ to ‘When Last Connected to This Mac’.

When Last Connected to This Mac

‘Automatically’ will switch your AirPods from being connected to another device if you stop using that device and start using your Mac. ‘When Last Connected to This Mac’ means your Mac doesn't participate in automatic switching and will only connect to AirPods when they were last connected to your Mac.

2
  • 30
    This turns off the entire automatic switching feature. Is there any way to get rid of the notification only? Commented Jan 4, 2021 at 18:48
  • 1
    This is not the answer, the question is how to get rid of the notification and not how to disable automatic connection
    – Vedmant
    Commented Apr 22 at 4:29
-1

I was having this same annoying issue so I disconnected my AirPods from the bluetooth on my MacBook Air and that seemed to work. Let me know if it works for you!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .