3

Is there a way to control the numa settings on the iMac (Core i7), OS X 10.7.3? MacPorts doesn't have numactl and tbb/openmp are both slowing down since the memory is allocated incorrectly.

  • numactl is linux specific. Even if you find it, compile it, you'll not be able to control anything. – mspasov Feb 21 '12 at 20:44
  • @mspasov: That is why the question is about how to control numa settings not how to compile numactl. – aterrel Feb 22 '12 at 5:13
  • @aterrel Can you describe numa more? What does it do? – CajunLuke Feb 25 '12 at 0:18
3
+50

Does Lion even support NUMA ?

For Snow-Leopard, I thought, there was no NUMA support. German article as source.

I could not find a source for NUMA support in OS X, thus I would say that there's as well no way to control the NUMA-settings ;)

This Intel document states:

On multi-socket machines based on the Intel® Core™ i7 processor, NUMA is typically available as a BIOS boot option, but effective use also requires some OS and some user-level intervention.

Windows* OS support for NUMA started with Windows* Server 2003, and Linux* OS support requires kernel 2.6 or higher.

No OS X mentioned.

  • 1
    Most likely OS X doesn't support NUMA because the only Macs which ship with multiple processor chips are some of the Mac Pros. It's probably a lot easier to build that one model with SMP than to add NUMA support to the operating system. – ughoavgfhw Feb 28 '12 at 0:53
  • @iolsmit Thanks for finding the details. I think the story is that the combination of no NUMA settings and bad gcc openmp implementation are causing the effects I'm seeing. – aterrel Feb 28 '12 at 18:13
0

Why you think you program is slow due to memory allocated incorrectly?

There's always only 1 NUMA node/domain on any iMac, so it is not even a NUMA system; and since it's not a NUMA system there's certainly no control.

For those dual socket Mac Pro, memory are always configured in interleave mode, because the mach kernel is not NUMA aware.

  • Sorry I don't have the benchmark code from 4 years ago. – aterrel Dec 13 '15 at 12:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .