1

I just bought a pair of AKG Y500 bluetooth headphones. They paired up ok to the Mac and first time played perfectly. However, if I switch off the headphones and switch them back on, the audio is choppy. The only way I have found to clear it is to reset the Bluetooth module, then it's fine until the next time I switch the phones off. Is there a fix for this? Surely I don't have to do this every time I switch the phones on?

2
  • It might have something to do with sample rate the bluetooth speaker operates, can you check if there is an option available once you connect your device? 44.1 should work just fine if you have the option to change so. Common thing among audiophile software, but I am not sure about the integrated sound settings within MacOS.
    – Berk Ilgar
    Commented Nov 14, 2020 at 15:46
  • Thx for that, However, I would have thought that it would be a permanent problem if that was the case. As I said it works first time, and then if I reset the bluetooth module it is all ok, it only occurs if I switch the headphones off, even for a second. Commented Nov 14, 2020 at 16:20

1 Answer 1

0

I had the same problem and tried tons of different solutions. After a lot of tries, this solved it:

Go to:  → System Preferences → General and uncheck the option Allow Handoff between this Mac and your iCloud devices.

Not the answer you're looking for? Browse other questions tagged .