0

I use LyX and I installed last version 2.3.5.2 on macOS Catalina 10.15.7.

Whenever I launch the application the system shows a progress bar saying 'Verifico "Lyx.app"...' (this is Italian, in English it should read something like 'Verifying "Lyx.app"...' or 'Checking "Lyx.app"...').

After that a window pops-up saying '"Lyx.app" รจ un'applicazione scaricata da internet. Confermi di volerla aprire?' (that translated is '"Lyx.app" is an application downloaded from internet. Do you confirm you want to open it?'), and I answer "yes".

This behavior is OK for the first run, but it repeats every time I launch the application, and seems more a problem of macOS than a problem of Lyx. Can someone help?

  • How and where did you install LyX? Did you copy it to /Applications? – nohillside Nov 13 '20 at 18:11
  • It is a .dmg file, and once opened it ask to drag the app in /Applications @nohillside – enzotib Nov 13 '20 at 20:59
  • And did you drag it and now run it from /Applications, or do you start it directly from the .DMG? – nohillside Nov 13 '20 at 21:16
  • @nohillside I dragged it in /Applications, unmounted the .dmg and I run it from /Applications – enzotib Nov 13 '20 at 23:13
0

I finally realized that the folder /Applications/LyX.app/ didn't have write permissions not even for the proprietary user, differently from all other *.app folders in /Applications, so the execution of the command

chmod +w /Applications/LyX.app

solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .