2

I am using macOS 10.14.6. After certain actions, such as starting the screensaver and other "innocent" things, the system locks up for about a minute. The mouse pointer can be moved, but nothing else reacts or moves on screen. I just have to wait it out.

Looking at the console, I can see six .crash files for tccd, with timestamps about 10 seconds apart, after each such event. The contents are like this:

Process:               tccd [11633]
Path:                  /System/Library/PrivateFrameworks/TCC.framework/Versions/A/Resources/tccd
Identifier:            tccd
Version:               221.260.3

...

Crashed Thread:        1  Dispatch queue: com.apple.root.default-qos.overcommit

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
dyld3 mode
*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '*** -[NSFileManager fileSystemRepresentationWithPath:]: nil or empty path argument'
terminating with uncaught exception of type NSException
abort() called

To trigger the problem, it is sufficient to open the Desktop & Screensaver preferences, which shows a preview of the screensaver.

UPDATE: Trying to choose the picture source for screensavers causes a several minutes long hang. It seems that the problem is with the screensaver trying to access data on disk. The picture source has always been set to the default though.

I have now completely disabled the screensaver to try to avoid this problem. But unfortunately, it is sometimes (non-reproducibly) triggered by other actions as well, typically either using dictionary lookup (with "force-click") or using quicklook in a file-chooser dialog. Of course, it always happens when I'm in a hurry and trying to get work done ...


What can I do to find the root cause of the problem, and resolve it?

This problem has persisted for several months now and I had no luck in diagnosing it, other than discovering the relationship to tccd, which is responsible for controlling the access of programs to "sensitive" user data.


UPDATE: The same problem is reported here and claimed to be related to security update 2020-004.


What I tried so far:

  • Reset the TCC database using tccutil reset All.
  • Here is it claimed that uninstalling Dropbox helped. I tried this and it made no difference.
  • The first link in your post mentions an OS reinstall, might be worth trying – nohillside Nov 14 '20 at 11:24
  • @nohillside Thanks for the comment! More accurately, he said that the purpose of the re-install was to get rid of security update 2020-004. Thus, the choice would be between having a security update that fixes zero-days or avoiding the UI hangs. At the moment I am not really willing to take the risk of a re-install as I cannot afford to be without a usable machine even for one day. If nothing better comes up, I might try the reinstall at a more relaxed time (work-wise). – Szabolcs Nov 14 '20 at 12:46
1

This problem is fixed by Security Update 2020-007. Instead of crashing, TCCD now prints the following warning into system log:

TCC From PID[xxxx]: realPath of reponsible path () fails: Receiver must not be nil or contain the empty string.

  • I confirm that after installing Security Update 2020-007 on my Mojave machine, I no longer see these hangs. – Szabolcs Dec 16 '20 at 18:07
1

I have nothing constructive to add at this point, other than to say I have what looks to be the exact same symptoms. Same version of MacOS, same one minute hangs (mouse moves, screen frozen, iStat Menu CPU history shows 0% for over a minute), been happening for several months and just found the reportcrashs for tccd. Mine occur in groups of 1 to 4 several times a week. Crash reports identical to yours.

I have not been able to find any rhyme or reason as to when they occur.

I'll post back here if I figure out anything and will watch to see if you make progress.

Thanks, Dale

  • I noted that security update 2020-006 became available a couple of days ago. I installed and have been clean since, but it is too soon to call it fixed for me. – Dale Hohm Nov 17 '20 at 14:14
  • The problem has persisted after my install of security update 2020-006 – Dale Hohm Dec 7 '20 at 15:28
  • TCCD is buggy since security update 2020-004 and when it receives invalid arguments, it crashes and freezes whole system for ~1 minute. Could everyone affected please report this to product-security@apple.com and include relevant crash report(s) in order to get this finally fixed. – phr Dec 9 '20 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .