17

We recently bought a used 1stGen iPad Air (MD788LL/A). It looks like we can't install the Netflix app because it requires iOS 13, and our iPad cannot be updated to that version of the operating system. Is there any way to work around this? Is it possible, for example, to watch Netflix in the Safari browser?

3
  • 3
    Have you tried going to netflix.com in safari? Just curious if that would work, don't see why it wouldn't unless they block ipad for some reason. Don't have ipad so can't check myself. – Kodos Johnson Nov 12 '20 at 19:08
  • At least related to apple.stackexchange.com/questions/378415/… – Grzegorz Oledzki Nov 13 '20 at 18:49
  • @Harper-ReinstateMonica Yes, if you have an old version of Netflix it will work fine. The problem is that new versions will not, and old versions are not available for download unless you already have it in your purchase history. – mweiss Nov 13 '20 at 20:46
37

It is a common thing among outdated apple devices.

If you have a friend, relative or access to any device with the latest iOS, just open up your account from them.

Install the app, delete it and log out.

Once you go back to your own device, the app will be listed in your "Purchased" section.

When you press download from there, the prompt will say something like (paraphrasing) "The latest version of Netflix is not compatible with your version of iOS, do you want to install latest compatible version?"

From then, you can install the app and use it up until Netflix cuts support for that version of app.

4
  • 1
    OK, so the limiting issue is being able to initially "purchase" the app into their App Store Account. (purchase price $0 of course). That makes sense, App store doesn't want to take your money for an app if you can't run the latest version. That explains my experience which is that Netflix installs fine for me on my ancient iPad. – Harper - Reinstate Monica Nov 13 '20 at 20:50
  • note: doesn't work with whatsapp – Luis Felipe Nov 14 '20 at 1:55
  • 1
    @LuisFelipe Not to doubt you too much—but are you absolutely sure it doesn't work for whatsapp? Whenever I've seen someone say this process doesn't work, it's because they weren't redownloading from the purchase history screen. – Wowfunhappy Nov 17 '20 at 13:46
  • Hello @Wowfunhappy, you can download the app in a previous version, but it will warn you that “you can only use WhatsApp with the last account associated to this device”. Here is a problem if you opened WhatsApp on a new device. I can go furthermore this step due to application login fails. You can download yes, but maybe you can login – Luis Felipe Nov 17 '20 at 13:49
4

If you don't have access to a newer iOS device, or don't want to mess up the accounts on your friend's phone, you can "purchase" an app through an older version of iTunes. Apple provides links for the last app store enabled iTunes versions.

Of course, not all apps will work on older devices, even if there's a version of the app that's compatible. For instance, an online game might no longer be supported on the game's servers. Or Netflix could drop support for older iOS devices.

3

If you're looking for a more long-term solution, you can probably jailbreak your iPad considering its iOS version. There are multiple jailbreak tweaks such as AppAdmin that allow you to download and install earlier versions of applications; you can find one that is compatible with your device, and then use it.

1
  • 1
    Best solution. Always jailbreak/root your device, take back control over your hardware. – JonathanReez Nov 14 '20 at 2:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .