0

Problem

A few weeks ago, I noticed that I could not add any new alarms on my iPhone. Eventually, I figured out what was going on:

  • Whenever I press any button that launches a time-based radio dial (one of the pop-up context menus that has you choose a time or date), the app crashes.

Attempts to Fix It

  • I thought this was just a problem with the Clock app (I just use the standard iPhone clock), but when I tested other apps that have the datetime radio button, like the transit app I use, the same problem occurred.
  • I don't seem to have any other problems, other than this time-radio-button. No other problems on other apps, and the phone otherwise is working fine.
  • I have tried all of the standard means of trying to fix something while in ignorance:
    • reboot the phone
    • reset all of the settings (that was a pain, but I did it)
    • uninstall and reinstall the offending apps
  • None of those efforts worked, and Google searching, I couldn't even find anyone who had a similar problem.
  • There was even an iOS update recently, and after the update, the problem was still there.

Any ideas on what could be causing the problem and what I might be able to do to fix it?

My iPhone details:

  • iOS version 14.2
  • iPhone Xs (model #: MT9J2QN/A)
  • 256 GB, with 214 GB free
0

Wow, after struggling for a while, I finally tried something that should have been obvious, and it worked:

  • I changed the time format from 24-hr to 12-hr, and now it is working OK.
  • To be clear, in case anyone else has this problem:
    • Settings ==> General ==> Date & Time ==> Toggle 24-Hour Time off

I do not understand why that worked; I have been using the 24-hr clock since I owned the phone a little over a year ago, and this just started happening a few weeks ago.


Does anyone know where I can report this to Apple? I suspect some auto-update introduced this bug, but I have no idea how to tell this to people who can actually track it.

(Too bad Apple does not use GitHub for anything...)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .