0

The event:

After updating to 10.15.7 on a Mid 2012 MacBook Pro and hitting first time the + key - "é", the keyboard layout changed to symbols (instead of asdfg I get åß∂ƒ©). I have only the "U.S." keyboard layout installed. A few years ago I had the Greek because it was easier to type greek letters, but removed it about 4 years ago.

Symptoms:

  • Of course I am unable to log in. /Sometimes I can, but I was unable to determine what sequence of trials /+, , , , +, +++

    , etc.../ sets it back to "U.S".

  • The "About This Mac" menu item under the Apple menu disappear. A new menu item "System Information" appears.

  • When I am in an Application - let's say Safari -, the "Quit Safari" menu item changes to "Quit Safari but keep the Windows"

Remedies tried:

  • All the key combinations and more listed above. Did not work
  • Chat with Apple Support twice. They had no clue but recommended to reformat and reinstall.
  • Reformated all volumes that Apple allows to reformat and reinstalled from the Base Mac OS. Did not work.
  • Reformated again and installed 10.14.6. Did not work. After the first hit of + or +, the keyboard layout changed to symbols. Upgraded it to 10.15.7, hoping it will wipe the Base Mac OS clean and updates the EPROM... Did not work
  • Tried to boot from an USB drive that is bootable and contains 10.15.7 but after the Installer rebooted the machine the install did not continued from the USB drive, but rather of the Base Mac OS stored on the internal drive. So, ultimately did not work.

Any good suggestion that will work to keep the "U.S" keyboard layout?

7
  • I see that the forum changed my keys I typed. So the key combo to change to greek was "option+e". This put the usual ' or ` first and when I hit "e" again it placed another one after it, instead of there "é" I expected. The keyboard physically is the built in hardware, so whenever in the post you see just + signs it is in reality Command+R, Option, Shift, Option+Shift, Option+command+P+R, D, C,etec key combos according to Apple Support documents. I just did not know that the forum changes anything between <> to nothing. – infocean Nov 10 '20 at 16:39
  • Sorry, I misinterpreted your question. so after typing asdfg I am getting Åß∂ƒ© – infocean Nov 10 '20 at 16:52
  • That's not Greek, it's just the just the variety of symbols you get when the machine thinks the option key is held down. Your keyboard might be damaged. Have you tried another keyboard (doesn't have to be from Apple)? – Tom Gewecke Nov 10 '20 at 18:18
  • When you hold down the option key and click on the Apple menu, you get "system information" instead of "about this Mac". Another confirmation that your problem relates to the machine thinking the option key is depressed even when it isn't. Same thing for the Safari Quit menu item. – Tom Gewecke Nov 10 '20 at 22:29
  • I tried an external keyboard, I use with my Mac Pro, the machine did not recognize it. No sticky keys are set. – infocean Nov 12 '20 at 6:36
0

It sounds like your machine thinks the Option key is always depressed. Make sure that you do not have Sticky Keys in Accessibility Preferences turned on. Try an external keyboard (doesn't have to be from Apple) and see if the problem persists or not.

3
  • No sticky keys are on. When I able to login, I see the "About This Mac" item under the Apple menu, and when I hold the the option key and click on the Apple menu it does not change to "System Information". This false sensing of the option key down happened only after I upgraded to 10.15.7. Either the Eprom or the EFI partition of the hard drive has some code activated and it is waiting just for a key down event or a trackpad tap event to mess up the keyboard layout. After restart the machine does not recognize cmd+option+P+R, although that must be very early in the boot process. – infocean Nov 12 '20 at 7:08
  • Today I was able to boot into Recovery Mode and looked into the log. I do not know how to attach pdf, so I type here a few messages from the "unknown" deamon: Unknown[596]: Language Chooser[595:2155] NSDisabledCharacterPaletteMenuItem=Yes later Unknown[596]: Setting boot completed. I never heard about "Unknown" deamons from Apple. Further Unknowns: Keyboard Layouts: duplicate keyboard layout identifier -17410 and Keyboard Layouts: keyboard layout identifier -17410 has been replaced with -28673. Additionaly, after a successful login I see Disk Utility launched by "Unknown" – infocean Nov 14 '20 at 5:36
  • There is a discussion on MacRumors regarding Catalina install on unsupported Macs. Mine is a Mid 2012, so it is still should be supported. When I looked my error log, I saw also these entries: MacBook-Pro Unknown[582]: Keyboard Layouts: duplicate keyboard layout identifier -17410. MacBook-Pro Unknown[582]: Keyboard Layouts: keyboard layout identifier -17410 has been replaced with -28673. MacBook-Pro Unknown[582]: Keyboard Layouts: duplicate keyboard layout identifier -14934. MacBook-Pro Unknown[582]: Keyboard Layouts: keyboard layout identifier -14934 has been replaced with -28674. – infocean Nov 18 '20 at 21:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .