I am unable to share my screen using Teams on my MacBookPro running Catalina with an external monitor. I have successfully shared a Powerpoint presentation through Teams, and on my other computer running Big Sur Beta I have been able to successfully share my screen.

I have tried to follow the advice that I have found on web pages here and at Microsoft, e.g. https://answers.microsoft.com/en-us/msoffice/forum/msoffice_o365admin-mso_teams-mso_o365b/macos-catalina-and-teams-screen-sharing/28a38edc-d149-4c32-95cd-95c4d87dbf13?messageId=000ad0d2-2025-400b-8fe1-f8285dc0f488&page=21&rtAction=1579206173825 where people describe similar issues. I have tried running Teams in full screen and windowed mode, on the built-in screen and external monitor. I have not tried disconnecting the external monitor.

I think that the problem is Teams not getting permission to share - every time I press the Security & Privacy settings button in Teams, it does launch the Settings window, Security and Privacy, but does not put a Teams row in the Screen Recording permissions frame for me to approve.

I have followed the advice to run tccutil to clear the Teams permissions on these pages, Mac Catalina And Microsoft Teams Screen Sharing Permissions https://silviustroe.com/cant-share-screen-microsoft-teams-fix/ and reinstalled the Teams app, and I have cleared all of the apps using "tccutil reset ScreenCapture" but still Teams does not appear in the Screen Recording permissions list when I try to share.

You must log in to answer this question.

Browse other questions tagged .