2

I have just got a new (2020) iPhone SE, and having an issue with iMessages.

I was previously in a group conversation - most of the recipients are phone numbers (with iPhones), but one is an iCloud email address. Since I got the new phone, I can't see any messages from the person using their iCloud address. And they don't see my messages. Everyone else in group chat can see our messages fine.

What's going on here? I've tried turning imessages on and off. Any other tips?

6
  • Have you tried directly messaging their iCloud email address in a separate iMessages conversation with them? Sometimes this might push things to update/work. Also check if they are in your/their contacts, and check in iOS Messages settings, that you are not filtering unknown contacts. – AVelj Nov 6 '20 at 11:50
  • When you say “iCloud address” are you in control of that address or is someone else in control of that address? The blocks and settings are very different based on who controls the password to that address. – bmike Nov 6 '20 at 11:54
  • @bmike - I am not in control of the icloud email address - it's a friends. – rw2 Nov 6 '20 at 12:50
  • @AVelj - I tried messaging separately and it fails. They are in my contacts, and I don't have that filter on. Thanks – rw2 Nov 6 '20 at 12:50
  • If you go to Settings->Messages->"Send and receive" on your new phone. Is the iCloud address listed and checked? Does it work as it should on you old phone? If you go to Settings -> [You name at top] -> iCloud. Is Messages turned on? – iTunes Nov 6 '20 at 17:40
1

If another iCloud account can’t see your messages, it could be as simple as they have blocked you. It could be more complicated that Apple thinks they blocked you so they would have to work with Apple support, but you can’t really tell what’s happening to someone else’s iCloud account by design.

If you send them a message that’s about all you can know was Apple accepted it from your device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .