I have a new MacBookPro 16" with a 500Gb SSD. Currently it has 332Gb of files on it.

I'm trying to run the first Time Machine backup, and it keeps failing because there's "not enough space".

By default, it estimates a full backup to be 674Gb.

Time Machine prefs with no exclusions showing estimated backup size of 674Gb

Even if I exclude the entire source drive, it reckons it will take 353Gb.

Time Machine prefs with entire drive excluded showing estimated backup size of 353Gb

Both drives show no errors when analysed with Disk Utility. Anybody know what might be going on?

  • The most common reason is if you have very large single files, like VM images - one change requires the whole thing to be backed up again.
    – Tetsujin
    Commented Nov 3, 2020 at 18:53
  • Thanks, but it surely still can't be possible for it to want to back up more data than can physically exist on the source disk? Or that if I exclude the entire source disk it still wants to back up 300 Gb of... who knows what?
    – calum_b
    Commented Nov 3, 2020 at 22:35
  • Do you have other drives than the Macintosh HD one?
    – jksoegaard
    Commented Nov 3, 2020 at 22:38
  • No, just that one. I eventually resolved the issue, but I'm still not sure what the problem was.
    – calum_b
    Commented Nov 5, 2020 at 11:23

1 Answer 1


I eventually resolved this, though I'm not sure exactly what the issue was. Steps I took:

  • Wiped and reinstalled the OS using a SuperDuper backup.
  • Initially, Time Machine then showed the 'correct' size estimate, but then quickly changed to the incorrect version again. At this point, it was also showing me a phantom Time Machine backup drive that I couldn't remove.
  • Now suspecting some corrupted settings, I switched to my admin account. Having wiped my SuperDuper backup to use as a Time Machine drive again, I tried to set up Time Machine there instead. Here, I could remove the phantom drive, and the size estimates looked correct.
  • I switched back to my user account, and added back my TM exclusion folders. Everything still looked good.
  • First backup completed successfully \o/

It's possible trying to sort things out in the admin account may have worked in the first place, without the full reinstall. I guess we'll never know...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .