1

I am connecting a Macbook Pro 13" 2016 to an external monitor (LG 27UL500), that supports up to 4K resolution. They are connected via HDMI and a HDMI-USBC adapter (Apple brand).

I have tried three resolution options:

  • 4K/UHD (3840 x 2160): sharp, but text/windows are too small.
  • FHD (1920 x 1080): amazing (Retina), but text/windows are too big.
  • QHD (2560 x 1440): very blurry, but text/windows are the right size. This last option is only available in the Display Options if I option-click the "Scaled" setting (instead of normal clicking).

I am confused by the fact that the QHD setting is significantly blurrier than the 4K setting. Online I have seen the explanation that in order to use the Retina option, one has to set the resolution to at most half the maximum (so FHD in my case). I see the difference, it is indeed nicer. But the "sharpness" of the non-Retina 4K is also fine for me.

Is there a way to get similar sharpness to 4K, while scaling windows to QHD, so that the windows/text are a bit bigger? Or is that simply not possible because 3840 is not divisible by 2560?

I have already tried the RDM software, which even gives a few additional options between 4K and FHD, but all of them are blurry. (Interestingly, the QHD setting via RDM is even blurrier than that same resolution set via System Preferences -- as in, text is almost unreadable. This makes me think there may be a software-related issue after all.)

Is there a fix in the settings / software? Otherwise, would a DisplayPort -> USBC adapter help? (instead of HDMI which I'm using now?)

3
  • 1
    See this existing answer re: LG display, blurry text.
    – Allan
    Commented Nov 3, 2020 at 16:11
  • Thanks for the suggestion. I would expect that if the cable were the problem, the screen would be blurry at all resolutions (especially the highest one). I am using a HDMI cable that came with the monitor, and this adapter to USB C.
    – Borage
    Commented Nov 4, 2020 at 13:52
  • That's not an active adapter. It must actually say "active" to be active. The cable could be the problem if it's not correct - not all cables are the same.
    – Allan
    Commented Nov 4, 2020 at 14:31

0

You must log in to answer this question.

Browse other questions tagged .