3

I cannot set any timezone on my Mac. If I go to Date & Time and pick any location I always get empty timezone.

Data&Time with timezone

Running: sudo systemsetup -listtimezones returns Time Zones:

When I try to set timezone from command line I go info about invalid timezone. What is interesting: /etc/localtime -> /var/db/timezone/zoneinfo/Europe/Warsaw

Still time is not correct for Warsaw timezone. I tried set automatically and not - nothing helps. (I did reboot laptop) I suspect there is some cache for timezones which is corrupted, but I don't know how to rebuild it.

System Version: macOS 10.15.6 (19G2021) Kernel Version: Darwin 19.6.0

3
  • Welcome to Ask Different. Have you allowed "Time Zone & System Customization" to use your location? Open System Preferences>Security & Privacy>Privacy, select Location Services and press the "Details..." button next to System Services to find out.
    – jaume
    Commented Nov 3, 2020 at 10:40
  • Yes it's enabled. Even when I put proper location manually there is no timezone. In fact if I select any location - still no time zone. I think that it's because systemsetup -listtimezones returns empty list for some reason.
    – mi_st_
    Commented Nov 4, 2020 at 11:10
  • Yes, systemsetup -listtimezones should return a list of time zones. Can you check if the directory /private/var/db/timezone exists on your Mac? It should contain a symlink to /var/db/timezone/tz/2020d.1.0/icutz, a symlink to /var/db/timezone/tz/2020d.1.0, a symlink to /var/db/timezone/tz/2020d.1.0/zoneinfo and a subfolder named tz.
    – jaume
    Commented Dec 6, 2020 at 13:26

1 Answer 1

2

I think you are encountering the same issue as Time in GMT or Missing Time Zones in systemsetup. I posted a solution there. In my case, I didn't even have the visual representation of the timezone on the map.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .