0

I have always used an Android phone, but text messages from certain friends get hijacked by iMessage. How do I prevent iPhones and MacOS Messages from sending me iMessages? I need all messages to be SMS or MMS.

Some friends with iPhones will text me, but I don't receive the message. Today I noticed the Message app on my Mac had notifications. I never open this app since I don't use iMessage, but I looked today, and found multiple "lost" messages from several weeks ago.

Please note that this is NOT the same question as Removing phone number from iMessage. My Android phone is not, and has never been, registered with iMessage, and I have already followed those instructions. Another poster (cpcallen) had the same question as me--How can I ensure that friends with iPhones send me SMS/text instead of iMessages?--but it was closed, being deemed as the same as the Removing phone number question. It's actually fairly different.

I have tried:

  • Leaving my Messages app closed on my Mac. But somehow messages from these people get hijacked.
  • Deregistering my mobile number using Apple's online Deregister iMessage tool. When I attempted this, I got the message "Your phone number is not registered with iMessage."
  • Finding a setting on my Android phone that addresses this. The problem is apparently (and logically seems to be) on the Apple end.

Things cpcallen says he tried:

  • Closing Messages.app. I still get macOS notifications of messages.
  • In Messages > Preferences… > Accounts > [my email address], untick "Enable this account". Then my friends messages disappear and I never see them at all, at least until I reenable in Messages.app.
  • Looking in System Preferences and on icloud.com and appleid.apple.com to see if there is some setting I can disable—but I've not found anything relevant.
  • Using Apple's Deregister iMessage tool to unregister my mobile number. When I attempted this it gave me the message "Your phone
    number is not registered with iMessage."
2
  • I know this likely isn't particularly helpful, but have you tried contacting Apple support? If the issue really is on their end (and it sounds like it might be), they may be the only ones who can fix it. – JMY1000 Nov 3 '20 at 5:50
  • 1
    Two ideas: Messages app preferences in MacOS has setting under iMessage tab 'You can be reached for messages at'. What if you untick everything except your phone number? You should also make sure that 'Start new conversations from' is set to your phone. Other than that - you have to contact friends with whom you have problem and let them check whether messages in their iPhones don't default to your e-mail address instead of phone number. Also keep in mind that if conversation thread with friend is started using e-mail all replies will default to e-mail as well. – Aivar Paalberg Nov 3 '20 at 14:20
2

You can not control how the sending phone addresses messaging much from your phone. As you mentioned, you have already deregistered your cell phone from Apple serves so that leads to the conclusion that your contacts are sending to your AppleID, by their choice.

Your only lever on the receive side is to change your AppleID to something no one knows. Then, you won’t have incoming iMessage transmissions by email or by mobile.

  • It’s likely not practical to get everyone to change their address book to clear their contact database to suit your preference, each time they make a mistake sending to your AppleID.
  • It’s also equally impractical to just block them entirely on Apple devices and hope they change the way they communicate.

But it never hurts to ask nicely, maybe people would change up their conversations instead of reusing the old conversation that is easy rather than checking the “to” closely.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .