I have activated the synchronisation of my Desktop & Documents Folders from my iMac to iCloud so that I can share it seamlessly to my Macbook Pro and my iPhone. This is working well.

I'd now like to prevent one of the folders inside the Documents folder to sync to iCloud. I see, for example, that the Microsoft User Data folder is not being synchronised because it is ineligible. That shows with a struck-through cloud icon. And I don't see this Microsoft folder appearing on my iPhone.

Apple documentation says that ineligible folders are usually because there is not enough iCloud storage for the element. That does not seem to be the case with my Microsoft User Data folder as it is only 40 Ko and I have nearly 1 GB available on my iCloud space. To me, it seems that behaviour is specific to the Microsoft directory.

How can I replicate that behaviour to another folder? I don't find any option for that.

Struck-through cloud icon

Does anybody know?

1 Answer 1


there are 2 name extensions that will stop iCloud syncing.

  • .nosync

  • .tmp

if you add .nosync to a folder name you will need to add it also to the folder contents.

if you add .tmp to a folder name it'll stop syncing the folder & its contents.

  • 2
    Is it possible to do it without changing the folder name? --Adobe automatically creates a folder inside Documents and I would like to avoid it syncing to iCloud, but changing the name is not possible.
    – gasbi
    Commented Mar 3, 2021 at 17:20
  • Is it really not possible to do this without changing the filename?
    – NSjonas
    Commented Dec 23, 2022 at 17:31
  • This might be relevant here: github.com/mitsuhiko/rye/issues/585. Thus, there is a way to do this programmatically.
    – a06e
    Commented Feb 5 at 13:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .