0

iPhone recently allowed me to set Chrome as the default browser, but this has not affected browsing from google maps. When clicking on a business location in google maps, then clicking on the website, it still always opens in safari. Any way for me to change this?

0

If I go to a business location and on their website via the google maps-app, the website is opened in the internal browser of google maps (and not in a external browser like safari or chrome.

When I click the icon on the right bottom, it's open the recent website in safari, but this icon refer to the safari browser.

enter image description here

  • If I copy the URL from the Google maps internal browser, and paste it somewhere else, it says "pasted from safari". HOWEVER, if I click the icon in the lower right it opens in Chrome, so that's a solution albeit with an extra step. – Tom B. Nov 3 '20 at 19:35
  • When I copy a link from any website in google maps and paste it anywhere, it pops up "...pasted from google maps". So I don't know what's going wrong by you... Go through the official apple documentation about Change the default web browser or email app on your iPhone, iPad, or iPod touch. Maybe it will help to go through the settings again – SwissCodeMen Nov 3 '20 at 22:21
  • Click on the link in Google maps, THEN copy the URL from the address bar, then paste. See what happens. – Tom B. Nov 4 '20 at 23:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .