0

I want to attach an external USB drive as a Time Machine target. What is the way to do this? I had thought Disk Utility would be able to help ..

This is Catalina on a 2020 Macbook pro . The external USB3 drive is connected via a USB <--> USB-C adapter to the Mac. The external drive power light is on so the electrical/physical connection is working.

But then Disk Utility only sees the original boot drive:

enter image description here

Update Here is the output from diskutil list (not present):

13:45:54/~ $diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         1.0 TB     disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +1.0 TB     disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            10.8 GB    disk1s1
   2:                APFS Volume Macintosh HD - Data     553.9 GB   disk1s2
   3:                APFS Volume Preboot                 81.7 MB    disk1s3
   4:                APFS Volume Recovery                535.6 MB   disk1s4
   5:                APFS Volume VM                      1.1 GB     disk1s5
5
  • Are any fsck processes running? (os postpones mounting until it knows if it’s read/write capable)
    – bmike
    Nov 1 '20 at 19:10
  • I assume you have rebooted while the drive is attached... Nov 1 '20 at 19:46
  • @bmike No there are no fsck related processes. Nov 1 '20 at 22:01
  • @SteveChambers A reboot is needed? I'll try that but it is surprising. Nov 1 '20 at 22:01
  • It is not needed but sometimes it is required. The joy of troubleshooting computers means you try things that don't make sense just because it is the easy thing to do. And the first easy thing to do for almost any troubleshooting is reboot. Mac or PC it matters not, a reboot fixes an assortment of puzzling issues. Nov 2 '20 at 0:06
0

You can see if the disk is attached easier in the command line.

diskutil list

Then if it’s recognized but not mounting, check for fsck processes. You can also click the view icon above where you selected Macintosh HD in your screenshot.

3
  • Thx Mike I ran the diskutil list and the external drive does not pop. Also no fsck processes. Tried before and after rebooting (twice) Nov 1 '20 at 22:04
  • Not looking good if this is the machine that won’t boot to recovery and also not mounting the drive. Hopefully it’s a cable or the drive and not the system needing repair @javadba
    – bmike
    Nov 2 '20 at 3:19
  • I'm going to have to cross fingers to get to Sunday when my homework is due ;) No backup in the meantime. Well the code will be in github at least. Reinstalling all would be less than ideal. Nov 2 '20 at 3:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .