1

I have tried with the last 2 public betas, as well as dev beta 9 and 10 (the current beta) and no matter whether i choose to upgrade from my existing catalina install, or make a bootable usb of all 4 of these betas (i have tried them all), wipe my hard drive clean and then install from fresh, ALL of them give me the error: "An error occurred preparing the software update"

This occurs after the initial copying of files during big sur set up, the machine then reboots and gives a message like "29 minutes remaining". I then get the message above and the Mac is totally bricked. It can only be fixed by doing an internet recovery of Catalina and then restoring with Time Machine back up.

A thorough search of the internet hasn't yielded any meaningful results aside from 1 thread on the dev forums where a few people had reported the same error and no answer was given.

I am using a 27" iMac 2019. Does anyone have any ideas what is causing this problem? I am now getting to the point that I'm worried I wont be able to actually install the final release when it is launched.

Thanks for any help you can give.

Screenshot

  • 2
    At the risk of sound flippant, Big Sur is in beta - it's pre-release software meaning it's going to have failures. You need to report this so Apple is aware. – Allan Oct 28 '20 at 22:05
  • 2
    And not to be pedantic here but "bricked" mean you have to throw the device away as it's only remaining utility is that of a brick. Your install "crashed" or "will not install" – Steve Chambers Oct 28 '20 at 22:37
  • This page may help you troubleshoot this problem. It may be as simple as making sure the iMac has the correct time and date set. Note: this page does not address beta software installation. – IconDaemon Oct 28 '20 at 23:24
  • Thanks for the replies. I have checked the date and time and they are correct. I find it hard to believe that I am only one of a few people with this error yet i can't seem to find it being posted about/replicated anywhere. Does anyone know what this error means or what causes it? Or what macos update assistant actually does? – hardtofin Oct 29 '20 at 0:02
  • I have now downloaded the newest public beta 11.0.1 which i have tried as a straight upgrade and made a bootable usb drive from. On both the attempted upgrade and also a clean install using the bootable usb with a totally formatted drive i encountered the same error as above. This means there have now been 5 versions of big sur beta i have tried to install, in both upgrade and clean install mode, ALL giving the exact same error. Any ideas? I don't seem to be able to find other people reporting this error elsewhere which is concerning. – hardtofin Oct 30 '20 at 15:38
0

This issue can still occur with the public release of Big Sur, 11.0.1.

In one case, this is network related. I don’t have the specifics but check to see if a simple restart of your modem solves the issue. If you are tech savvy enough to make sure you have obtained a new public IP, ensure that you do.

Not the answer you're looking for? Browse other questions tagged .