3

I have here a very strange case...

I have a MacBook Pro 13" (A1278) from 2010. Inside it is a 1TB FireCuda SSHD (ST1000LX015) hybrid hard drive.

The MacBook was working perfectly until a recent system update.

Suddenly, the hard drive became totally undetected when within the MacBook: the system cannot boot and the hard drive is totally unvisible; it does not show when holding down the Alt key at start (just after powering the MacBook on).

However:

  • The hard drive is physically in perfect condition, with all SMART values checked OK.

  • The volume is in perfect condition. (checked with OS X disk utility)

  • The partition table is in perfect condition (checked with the disk utility from another MacBook, with the drive in an external enclosure)

  • The system loads perfectly if the hard drive is put in an external enclosure and the MacBook booted from there.

So, I first suspected the SATA cable (altough looked in perfect condition), but:

  • Some hard drives with the Apple logo are detected.

  • Other hard drives from all brands (Seagate, Western Digital, Toshiba, Hitachi), but with non-Apple firmware, are not detected. By "not detected" I mean that the drive is not listed when holding down the Alt button at start.

I tried several times to make sure that the problem was not coming from the cable.

The Apple Store told the problem was coming from the hard drive, but it is wrong as thus is in perfect condition.

Conclusion:

  • I suspect some white list of hard drives was introduced at BIOS level by some upgrade of the system, possibly to attract customers into Apple stores.

  • I don't know yet if there is a firmware white list or a hard drive model white list.

  • I would like to hear if some of you experience similar cases.

  • Apart from using Apple-branded hard drives, any solution to solve this issue is welcome.

Note: holding down Cmd + Alt + P + R did not solve anything.

  • 1
    Please don't edit the question after the fact to insert an 'answer'. Answers go in the answer section below. Additionally, the answer you have placed below is really just a "me too" of the actual answer. You should accept the answer that gave you the solution by checking the green 'tick' next to it, rather than posting your own agreement to it separately. – Tetsujin Oct 27 at 13:13
13

No, there is no white list of acceptable replacements for storage disks held in firmware.

Apple doesn't make their own drives. Hard drives are made for Apple by Toshiba and Seagate, and the supplied drives are not 'custom built': they just meet a certain spec.

I've replaced the hard drive on hundreds of Macs and never had a problem of this sort.

You say that the SATA cable "looked in perfect condition" and you "tried to make sure that the problem was not the cable". You can't tell by looking at it if the cable is faulty. What did you do to test the cable?

I would definitely try replacing the SATA cable, as they are a well-known point of failure on those models. The fact that the drive works externally but not internally would suggest that.

(Though to be honest, I would recommend getting a 1TB SSD, as this would significantly improve your Mac's speed.)

| improve this answer | |
  • 1
    Thanks benwiggy. Before reading your answer, I just replaced the SATA cable, and yes it was the cause of the failure. I was fully aware that hard drives are made for Apple by Seagate, Hitachi, Fujitsu, but the hard drives for Apple are customized with OEM firmware (although other drives work). In the past, we have seen OEM white-listing only allowed hard drives. This was the case for the IBM ThinkPad T43. I noticed on the cable the presence of a circuit board with a 5-legged chip. I don't know what it does, but assume the problem could also possibly come from it. – OuzoPower Oct 27 at 12:51
  • Thanks for the 1TB SSD suggestion. I'm aware of it, but it's not my computer. As for now, the price is also not the same, especially for reliable SSD models. – OuzoPower Oct 27 at 13:03
  • 1
    @OuzoPower You should accept this answer and possibly edit in the details you wrote in your own answer, as this was what made you resolve your problem. – Thorbjørn Ravn Andersen Oct 27 at 23:24
  • As someone who's replaced drives -- and SATA cables -- in many a MacBook, this is overwhelmingly the first thing I'd try when the MBP had issues where it mysteriously could not see its startup disk. It got to the point where, even as just the in-house IT shop for about 100 MBPs, I insisted on maintaining a spare cable in inventory at all times. My managers complained, but came to appreciate the rapid turnaround of me slapping a new cable in and sending a laptop back on its merry way (after testing of course), then ordering a new spare. – Doktor J Oct 28 at 13:42
  • Nitpick: "Apple doesn't make their own drives. Hard drives are made for Apple by Toshiba and Seagate, and the supplied drives are not 'custom built': they just meet a certain spec." This implies to me that there's no detectable difference between an Apple drive and a non-Apple drive, which I don't think is quite true! For example, TRIM is disabled by default on non-Apple drives. The fact that Apple doesn't make their own drives doesn't mean they couldn't introduce a whitelist, if they wanted to. – Wowfunhappy Oct 29 at 4:01
3
  • The problem was coming from the SATA cable. Replacing it solved the problem.
  • The failure was difficult to diagnose because intermittent.
  • Beware of the cable length. One MacBook Pro A1278 from other year could provide a similar compatible cable, but the cable length was different: ok for testing purposes, but not for a replacement.
  • According to other posts, MacBook Pro from 2012 experience similar failures.
| improve this answer | |
  • 1
    If the problem was the cable, why did it not become evident until the system upgrade? – gidds Oct 27 at 23:00
  • @gidds SATA cables don't always fail all at once -- often just the signal integrity degrades and they start generating more and more errors. Maybe the new version rejects drives with too many errors? Or maybe something about the way it queried the drive changed to trigger the failure? Or maybe just a coincidence of timing. – Gavin S. Yancey Oct 28 at 0:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .