0

I would like to have a shortcut to open my terminal emulator "Alacritty". It is installed as a mac app (.app directory) and a standalone executable. (Installed via brew)

I made an Automator action for it, which I then could bind to a system-wide shortcut in the System Settings. The desired action would be: a) The app launches with the icon and b) opens a new instance everytime the run the action (not just brings the current window to focus).

The following things were tried but failed in one way or the other:

  1. Use the "Launch Application" action from Automator. This won't work, because instead of creating a new instance of Alacritty, it focuses the old one.
  2. Use the "Run Shell Script" action and just enter the binary path. This works, but the Alacritty instance doesn't have its icon.
  3. Use the "Run Shell Script" action, but enter "open /Applications/Alacritty.app". This seems to work when I run it from Automator. However when I run it using the shortcut, it still lacks the icon.

Are there any other options I haven't explored? Thanks!

  • Using open -na '/Applications/Alacritty.app' in a Run Shell Script action in an Automator Service/Quick Action does work to open a new instance of Alacritty as long a it doesn't have focus. Alacritty for some reason is eating my keyboard shortcut when pressed. If I ⌥-Tab to another application and then press the keyboard shortcut, it opens another occurrence of Alacritty. I'll play with it some more and see if I can figure out a workaround. – user3439894 Oct 24 at 3:13
  • Okay, as a workaround and using the same keyboard shortcut after removing it from System Preferences > Keyboard > Shortcuts > Services, using FastScripts and an AppleScript script, that is just do shell script "open -na '/Applications/Alacritty.app'", I was able to open multiple occurrences of Alacritty while it has focus. FastScripts is free to use with up to 10 shortcuts! – user3439894 Oct 24 at 3:23
  • @user3439894 Yeah, Alacrittly consumes the shortcuts, but that's actually not dramatic. I could register the shortcut in the alacritty.yaml. i'll check out the open -na trick tomorrow. – Filius Patris Oct 24 at 7:55
  • Didn't work... Still shows no icon and I also get weird permission issues, where I cannot access directories like Desktop/ and Downloads/ ... I'm sticking to the "Launch Application" action for now, since I realized you can launch new instances from within Alacritty. – Filius Patris Oct 25 at 14:58

You must log in to answer this question.

Browse other questions tagged .