2

Today, something weird is happening: when I try to print (from TextEdit) from my iMac (2017, Retina 4k, running Mojave, printing to a network-connected HP 3055), it ACTS like the document printed, but nothing comes out. I tried cycling power on the printer; no joy. I tried rebooting; no joy. I tried removing and reinstalling the printer; No joy. I tried printing from other applications (Preview, OpenOffice); no joy. From the "HP LaserJet 3055..." application, I CAN'T print a test page, but I CAN reach the printer's web interface, and print a PCL font list from it.

When I copy the document that started this whole mess over to my old Mini (running Mountain Lion, I think), it prints FINE from there. But still no joy printing from my Mini.

Any insights?

  • Try resetting your printing system and then re-adding your printer. In System Preferences → Printers, right click anywhere in the empty space where your printer(s) are listed. A context menu will come up with "Reset Printing System." Be aware, it sets everything back to the beginning so any saved settings will be gone. – Allan Oct 23 at 22:57
  • That was one of the things I tried ("Reset Printing System" being the "removing" part in my original post). – hbquikcomjamesl Oct 25 at 15:01
  • There's an issue out there concerning HP drivers and revoked certificates. Try using your Mountain Lion mini as a print server by sharing it and then have your iMac print to that machine. – Allan Oct 25 at 16:13
2

HP asked Apple to disable the HP software last Friday and then re-enable it. You can change the driver to AirPrint and know it you need to apply updates and reinstall your print drivers if that works.

See my answer here for how to manually install a fix if you don’t want to let Apple software updates fix your HP.

| improve this answer | |
  • Trying it now. Thankfully, I don't have that problem at home, on my Mac (a "Bionic Desk Lamp" iMac, physically incapable of running anything past Leopard) or on my DOS box (WordPerfect has its own PS and PCL drivers; Xerox Ventura Publisher uses a GEM PS driver, and anything else simply treats it as if it were a line printer). – hbquikcomjamesl Oct 26 at 21:49
  • 1
    And I just heard the 3055 process a page I just printed from TextEdit. – hbquikcomjamesl Oct 26 at 21:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .