1

I've been trying to download some softwares. I've deleted those files, but now, I think my zsh file keeps wanting to source a file that's no longer there. Because of that, I get the following message every time I open up my terminal:

zshrc:source17

This is really annoying, and I'd like to get rid of it somehow... Thanks!

1
  • The error message names the file where the error occurs, and even the line number of the error. You want to remove the erroneous lines in a text file. Where is the problem? May 24, 2022 at 6:07

2 Answers 2

1

I was able to solve this issue with the following steps:

Open .zshrc and edit it. This can be done with the following:

sudo nano ~/.zshrc

From here, you may find a file, whatever it may be named (in this case, it was sourceme.sh). Delete the line that was installed in there. There are many reasons it's in there using nano. Then, save.

Where sourceme.sh came from: I downloaded another program that automatically wrote that line in when I configured it, and when I deleted, it could no longer find that file. It could be any other shell script (.sh).

1
  • Why sudo if you just want to edit your own file? May 24, 2022 at 6:04
-1

The solution that worked for me is the following: https://code.visualstudio.com/docs/supporting/faq#_resolving-shell-environment-fails

6
  • 1
    See meta about link only answers as per meta SE
    – mmmmmm
    May 18, 2022 at 8:32
  • That is a super link. For you was it nvm or just that you ran code after having a command line shell successfully finish startup?
    – bmike
    May 18, 2022 at 9:26
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review
    – agarza
    May 18, 2022 at 13:14
  • @agarza You are quite right about that. How do I include the essential/relevant part? Should I upload a screenshot? May 19, 2022 at 10:24
  • @bmike I used to open up VS code and the error would pop up every time, but I would ignore it because things used to run smoothly, even though this happened. Then I had an issue when I tried to use my terminal separate from VS code; I noticed that it would first run a process before I was able to use it. Then I went back to VS code and saw that error was there too. May 19, 2022 at 10:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .